[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: transparently decrypting/encrypting gpg files from Gnu Emacs 25.2.1

From: Rainer Thiel
Subject: Re: transparently decrypting/encrypting gpg files from Gnu Emacs 25.2.1
Date: Tue, 29 Aug 2017 15:36:46 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.2 (windows-nt)

Thank you, Nikolay,

I think I've got it right, though I am still not sure what had happened.

gpg2 was in the right place, and it did use the keyrings in ~/.gnupg,
but for some reason that escapes me it was not able to find them when
called from emacs.  When I followed the advice from
that you kindly pointed me to, of a sudden gpg2 (called from the command
line), GPA and Kleopatra (key managers provided with Gpg4win) did not
find the keys anymore, either.

Therefore, I uninstalled and re-installed Gpg4win and imported the keys
from a backup.  Since I have done that, everything works as expected
again, with one pleasant side effect:  When trying to open a .gpg-file
from Emacs, I am asked for the pass phrase in the minibuffer instead of
in a Windows™ window.  Which is what I want and failed to achieve

Thanks again and best regards


On 2017-08-28, 23:18 +0300, Nikolay Kudryavtsev
<> wrote:

> Hello.
> Maybe you've already tried the stuff I'm going to propose, but still
> it's worth to be sure:
> Try running "where gpg" from Emacs shell, to see whether you have any
> possible culprits at the top of PATH. For example git carries its own
> gpg, so does msys2, maybe one of them is higher in your path and broken.
> After that please see this message about possible gpg config settings
> that may be in your way:
> It's very possible that you have a case like when gpg has its stuff in
> ~/.gpg, while it's looking for it in appdata.

Prof. Dr. Rainer Thiel
Institut für Altertumswissenschaften
07737 Jena, Germany (EU)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]