[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: can't open the same buffer in a second frame

From: Dale Snell
Subject: Re: can't open the same buffer in a second frame
Date: Tue, 5 Dec 2017 13:50:29 -0800

On Tue, 5 Dec 2017 16:30:31 -0500, in message, ken wrote:

> It used to be nice that I could open the same buffer in a second
> frame (aka window).  Sometimes I need to edit the same file in three
> or four places and it's necessary to have all of them showing at the
> same time... and for other reasons.  But I tried doing "C-x 5 b" and
> also "C-x 5 f" yesterday and couldn't do it either way.  I could open
> a different (not currently open file or buffer), but couldn't open
> the same one.  It worked years ago. Why take away perfectly good and
> useful functionality?  More importantly, how do I get it back?

I tried this here, and both "C-x 5 b" and "C-x 5 f" worked just
fine, though they both wanted me to specify the filename.  "C-x 5 2"
opened a new frame and automatically displayed the buffer from
the previous frame.

I suspect that there is something in your ~/.emacs.el
configuration that is causing this.  Best thing to do is do
a binary search of your configuration.  I.e., comment out half of
the config and save it.  Run emacs and see if the problem has gone
away.  If not, comment out half of the remaining config and try
again.  If it has gone away, un-comment the section you just
commented and try again.  Rinse and repeat until you've found the
errant config.

Hope this helps.


“Always do right -- this will gratify some and astonish the rest.”
    -- Mark Twain (1835-1910) 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]