[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Emacs 26.1: ./configure does not find my GTK

From: a . daniel . eliason
Subject: Emacs 26.1: ./configure does not find my GTK
Date: Fri, 16 Nov 2018 07:29:37 -0800 (PST)
User-agent: G2/1.0

I'm trying to compile from the current 26.1 tarball on CentOS..  It stops 
because it can't find by GTK. Anybody have similar problem?

My GTK libs are in to /usr/lib64:

  -bash-4.2$ ls /usr/lib64/libgtk*
  /usr/lib64/  /usr/lib64/  
/usr/lib64/  /usr/lib64/

There is no GTK in my 32 bit libs, however:

  -bash-4.2$ ls /usr/lib/libgtk*
  ls: cannot access /usr/lib/libgtk*: No such file or directory

When I run./configure, it does not find the 64 bit libs, apparently:

  checking for GTK... no
  checking for GTK... no
  checking for DBUS... yes
  checking for dbus_watch_get_unix_fd... yes
  checking for dbus_type_is_valid... yes
  checking for dbus_validate_bus_name... yes
  checking for dbus_validate_path... yes
  checking for dbus_validate_interface... yes
  checking for dbus_validate_member... yes
  checking for GSETTINGS... yes
  checking whether GSettings is in gio... yes
  checking for GOBJECT... yes
  checking for lgetfilecon in -lselinux... yes
  checking for LIBGNUTLS... no
  checking for LIBSYSTEMD... no
  checking sys/inotify.h usability... yes
  checking sys/inotify.h presence... yes
  checking for sys/inotify.h... yes
  checking for inotify_init1... yes
  checking for xaw3d... no
  checking for libXaw... configure: error: No X toolkit could be found.
  If you are sure you want Emacs compiled without an X toolkit, pass
  to configure.  Otherwise, install the development libraries for the toolkit
  that you want to use (e.g. Gtk+) and re-run configure.

I did try "yum install gtk+", and it did a bunch of work, but it made no 
difference.  I even tried installing "xaw" from yum, 'cause I saw ./configure 
was looking for it, but that made no difference either.

I tried setting LD_LIBRARY_PATH, but it did not help

  -bash-4.2$ echo $LD_LIBRARY_PATH

My /etc/ is

  -bash-4.2$ cat /etc/
  -bash-4.2$ cat /etc/*.conf

It seems like emacs ./configure really doesn't know how to deal with the 64 bit 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]