[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Fatal error 11: Segmentation Fault

From: Emanuel Berg
Subject: Re: Fatal error 11: Segmentation Fault
Date: Wed, 03 Apr 2019 09:49:20 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.1 (gnu/linux)

Eli Zaretskii wrote:

>> Move (package-initialize) from ~/.emacs [1]
>> to elpa.el [2] then byte-compile [3] with
>> 'emake', which is
>>     make $@ -s -C ~/.emacs.d/emacs-init # [4]
> What does this do, exactly?

OK, let's kill and yank some from make(1)...

    $@  all arguments (files), typically not used
    -s  -s, --silent, --quiet (except for error messages)   
    -C dir Change to directory dir (i.e. invoke it from wherever)

It executes the Makefile [1] which turns all
the .el's into .elc's.

>>     $ emacs --debug-init # works, but try again...
>>     $ emacs --debug-init # Fatal error 11: Segmentation fault
> What happens if you invoke Emacs in the same
> way the 3rd, 4th, etc. time? Does it crash on
> every invocation except the first, or on every
> second invocation, or something else?

It crashes every time since the first time.
Even if you do `kill-emacs' and run it again,
it crashes. It crashes until you do
'emake clean' (same Makefile) and byte-compile
again. Then it works one and only one time.

> It is possible that some of your
> customizations write something to the disk,
> and that triggers the problem the next time.

Possible. BTW I upgraded all the [M]ELPA
packages to their latest versions. Same thing.

> If you want to help us find the culprit, run
> Emacs under GDB (install Emacs with symbols
> if needed), and file a bug report with the
> C backtrace, using "M-x report-emacs-bug
> RET".

OK, maybe it will happen...

> Another alternative is to upgrade to Emacs
> 26, perhaps this problem was already solved
> during development after Emacs 25.

Oh, no! I just upgraded the system and
installed Emacs 25 from the repos. Besides it
will be a ton of work to move all the files to
Emacs 26, and I already tried that, back when
I was on Emacs 24. I couldn't get a separate
directory going for the init files and in
particular I couldn't get Emacs-w3m to work.


underground experts united

reply via email to

[Prev in Thread] Current Thread [Next in Thread]