[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Tramp shows no user/host completions (solved while writing)

From: Tassilo Horn
Subject: Re: Tramp shows no user/host completions (solved while writing)
Date: Sat, 26 Oct 2019 23:51:06 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

Michael Albinus <> writes:

> Indeed. When I complete "/ssh:f TAB" with one of `emacs21', `emacs22'
> or `basic' in `completion-styles', I see the call
> (file-name-all-completions "ssh:f" "/")
> which performs host name completion in Tramp. For the other completion
> styles, there is just
> (file-name-all-completions "ssh" "/") ;; for `partial-completion'
> or
> (file-name-all-completions "" "/") ;; for `substring' and `flex'
> or even no call for `initials'.

Would you consider that a bug?

At least from a user perspective, it seems odd that more powerful
completion styles restrict the completion candidates, though I do
understand the technical details that lead to the observed results.

> So I have added the following sentence to the Tramp manual:
> User name and host name completion is activated only, if file name
> completion has one of the styles ‘basic’, ‘emacs21’, or ‘emacs22’.
> *Note (emacs)Completion Styles::.

Good.  (But it would be better if it wasn't needed.)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]