[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 'apt build-dep emacs' has unmet dependencies

From: VanL
Subject: Re: 'apt build-dep emacs' has unmet dependencies
Date: Sun, 05 Jan 2020 21:11:15 +1100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.3 (berkeley-unix)

>> ,----
>> | % sudo apt build-dep emacs
>> | The following packages have unmet dependencies:
>> |  builddeps:emacs : Depends: librsvg2-dev but it is not going to be 
>> installed
>> |                    Depends: libgtk-3-dev but it is not going to be 
>> installed
>> |                    Depends: libasound2-dev but it is not going to be 
>> installed
>> |                    Depends: libmagick++-6.q16-dev but it is not going to 
>> be installed
>> | E: Unable to correct problems, you have held broken packages.
>> `----
> This indicates that your apt knows which packages it needs to install,
> but does not know of a repository from which to install them.
> What is in your /etc/apt/sources.list (and /etc/apt/sources.list.d, if
> any)? Have you done a ‘sudo apt update’ recently?

The entry in sources.list uses

  deb buster...
  deb-src buster...
  #deb buster...
  #deb-src buster...

When it worked what I did different was have the git clone of Emacs on
file system before calling 'sudo apt build-dep emacs', I also had
firefox installed which might have put in place the dependencies now
complained about.  It worked the first time, but not after reflash then
the second.

I had to reflash the RPi4B because the first experience update actually
errored and failed due to lag reaching, but the UI put
on a cheerful OK button to reboot.  That I didn't do.  

Although I pointed at a closer mirror and did the update again before
first reboot it bugged me until xload registered 50x plus when I decided
to reflash.  My RPi4B came in a box without electrostatic bag which was
disappointing.  The paperwork in the box shows a diagram of the RPi4B in
an electrostatic bag.

Before the second try, I also had commented out in 


  #deb buster
  #deb-src buster main

uncommenting those, now, gives me 56 upgrades and 1 new package.  But so
slow to update

looks like raspberrypi needs to fan out to cdns in regions.  

I uncomment in /etc/apt/sources.list

  deb buster...
  deb-src buster...

that does not give me more packages to upgrade.

Now, I am able to run 'apt build-dep emacs' successfully.  

The content

was needed.

Thanks YK for the push in the right direction!

-- VL

reply via email to

[Prev in Thread] Current Thread [Next in Thread]