help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacs 28: Specific TTF font gets loaded with font-backend x instead


From: Tassilo Horn
Subject: Re: Emacs 28: Specific TTF font gets loaded with font-backend x instead of ftcrhb
Date: Tue, 04 Feb 2020 19:32:08 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.0.50 (gnu/linux)

Robert Pluim <address@hidden> writes:

Hi Robert,

I've now tried at home with my own computer (also running Arch) and got
the same issue so it is at least not machine specific.

> Could you try uninstalling the system package, and installing the
> 1.0.2 version using the fonts tool? Just open the font(s) from your
> file manager, and there will be an 'install' button at the top right
> which will copy it somewhere under ~/.local/ rather than the system
> directories.

I did that, and now it works just fine.  Is there something different
(except for the location) when installing a font by just copying the ttf
files to /usr/share/fonts/TTF/ and installing them with the Fonts tool?
I mean, now it works with the very same ttf files I've previously copied
to /usr/share/fonts/TTF/ (replacing the files installed by the Arch
package).

Hm, another minor thing: when I compare the rendering of the above
paragraph in gedit and emacs, there are slight differences for some
glyphs.  For example, the F in TTF is slightly higher than the Ts, and
the y is slightly lower than, e.g., an a or o.  In gedit, their height
is equal.

>     Tassilo> Not that I know of but I'm no font config expert.
>     Tassilo> Usually, it just works...
>
> I took a look at the Arch jetbrainsmono-1.0.1 package, and it wants to
> install 'xorg-bdftopcf', which is used for converting fonts from
> bitmap formats, which is somewhat strange for a TTF font.

I think that's an indirect dependency of xorg-font-utils but I don't
know why that is needed.  I think, it isn't.  At least the installation
recipe just says "copy the TTF files to /usr/share/fonts/TTF/ and make
them readable".

  
https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/ttf-jetbrains-mono

Bye,
Tassilo



reply via email to

[Prev in Thread] Current Thread [Next in Thread]