help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacs 28: Specific TTF font gets loaded with font-backend x instead


From: Robert Pluim
Subject: Re: Emacs 28: Specific TTF font gets loaded with font-backend x instead of ftcrhb
Date: Tue, 04 Feb 2020 21:11:57 +0100

>>>>> On Tue, 04 Feb 2020 19:32:08 +0100, Tassilo Horn <tsdh@gnu.org> said:

    Tassilo> Robert Pluim <rpluim@gmail.com> writes:
    Tassilo> Hi Robert,

    Tassilo> I've now tried at home with my own computer (also running Arch) 
and got
    Tassilo> the same issue so it is at least not machine specific.

I spun up an Arch VM, and the system jetbrains mono package works fine
there.

    Tassilo> I did that, and now it works just fine.  Is there something 
different
    Tassilo> (except for the location) when installing a font by just copying 
the ttf
    Tassilo> files to /usr/share/fonts/TTF/ and installing them with the Fonts 
tool?
    Tassilo> I mean, now it works with the very same ttf files I've previously 
copied
    Tassilo> to /usr/share/fonts/TTF/ (replacing the files installed by the Arch
    Tassilo> package).

Not that I know of, as far as I know it just does the moral equivalent of
'fc-cache' somewhere.

    Tassilo> Hm, another minor thing: when I compare the rendering of the above
    Tassilo> paragraph in gedit and emacs, there are slight differences for some
    Tassilo> glyphs.  For example, the F in TTF is slightly higher than the Ts, 
and
    Tassilo> the y is slightly lower than, e.g., an a or o.  In gedit, their 
height
    Tassilo> is equal.

That sounds like there are hinting differences. Cairo doesn╩╝t always
obey the Gnome Tweaks hinting settings. The following might help:
<https://www.kilobitspersecond.com/2009/04/17/ubuntu-font-hinting-you-a-cautionary-tale/>

Robert



reply via email to

[Prev in Thread] Current Thread [Next in Thread]