[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Cannot run executable from eshell

From: Roy Lemmon
Subject: Cannot run executable from eshell
Date: Thu, 19 Mar 2020 14:18:31 +0000


I have an executable (guix) in a directory under my home directory. I am
using eshell. I add that directory to PATH. But when I run the command, the
executable is not found. I have tried various methods such as addpath etc.
But eshell doesnt seem to search in that directory and find the executable.
If I give the full directory on the command line, it works.

See below:

$ /home/rlemmon/.guix-profile/bin/guix works correctly

$ guix does not work

$ echo $PATH $ /home/rlemmon/.guix-profile/bin:/home/rlemmon/bin:/ ...

$ addpath

/home/rlemmon/.guix-profile/bin/ /home/rlemmon/bin/ ...

All of this is done within eshell. I am confused as to what the problem
might be. Is there a standard way to set the directories where eshell looks
for executables ?

Note that I am using EXWM (under nixOS) and starting the eshell via a
command defined in my init file. Though the same situation exists if I
start it via M-x eshell.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]