[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacs 26.3 strange ESS init error regarding Projectile and project r

From: Philip Kaludercic
Subject: Re: Emacs 26.3 strange ESS init error regarding Projectile and project root.
Date: Fri, 18 Jun 2021 08:59:06 +0000

Carlo Tambuatco <> writes:

> I probably will report this issue to them soon. But the strange thing is, 
> on my other computer, a Mac, I run emacs 28.0.50, a newer version than 
> the emacs 26.3 version I run that is giving me this problem. But I use the 
> same version of ESS on 28.0.50, which gives me no problems whatsoever 
> on that newer version of emacs.
> Something tells me they took ESS in a different direction with no thoughts 
> on backwards compatibility. 

project.el should be compatible with Emacs 26.3, if not that would be
considered a bug.

> In the meantime, I would like to perhaps down 
> grade the ESS version to a version that defininately works on emacs 26.3. 
> Is there a way to do that with elpa…?

Not directly, you could checkout the repository on an older version,
then package-from-buffer the elisp directory.

>> On Jun 17, 2021, at 3:56 AM, Philip Kaludercic <> wrote:
>> Carlo Tambuatco <> writes:
>>> Unfortunately, reinstalling ESS did not solve the problem. I even tried
>>> uninstalling
>>> and reinstalling emacs itself to no avail. I don't know when this problem
>>> occurred
>>> or why but the combination of ESS and emacs-26.3 simply does not work. For
>>> some reason, the ESS package still gives me this error:
>>> "project-root is already defined as something else than a generic function"
>> Have you reported this issue to the ESS developers? From what I see they
>> appear do be doing something wrong, as project-root is a generic
>> function defined in the core, and they are apparently trying to
>> use the same symbol for a regular function.
>> -- 
>>      Philip K.

        Philip K.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]