[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Issues installing packages from melpa

From: Akber Khan
Subject: RE: Issues installing packages from melpa
Date: Wed, 13 Oct 2021 14:42:24 +0000

Hi Janelle and Phil,

Good suggestion! 

So I ran the command "emacs -Q", and in my init.el file I uncommented the 
portion with the lisp code that inhibits the default init file: 

(setq inhibit-default-init t)

- I think -Q handles that, but I made sure to uncomment that just in case. 

I checked the *Messages* buffer, and upon load, this was all I got: 

For information about GNU Emacs and the GNU system, type C-h C-a.

When I open the package manager, all that's available are packages from the gnu 
archive, and indeed none of those show the "Process connection broken 
by remote peer" error message in their description. However, I also want to add 
the melpa archive, so in that same vanilla session, I added the archive with: 

(require 'package)
(add-to-list 'package-archives '("melpa" . "";) t)

I don't see anything in *Messages* when I run that code, but when I open the 
package manager, it never seems to finish loading the package list. The text I 
see in the buffer status menu is: "(Package Menu: Loading)", and all I can see 
are installed, built-in, and gnu archive packages.

Nothing more seems to happen, but when I click on any of the gnu packages, the 
following appears in the *Messages* buffer: 

Contacting host:
gnutls.el: (err=[-54] Error in the pull function.) boot: (:priority 
NORMAL:%DUMBFW :hostname :loglevel 0 :min-prime-bits nil 
:trustfiles (/etc/ssl/certs/ca-certificates.crt) :crlfiles nil :keylist nil 
:verify-flags nil :verify-error nil :callbacks nil)

I got a slightly different message when trying again on another package: 

Contacting host:
gnutls.el: (err=[gnutls-e-invalid-session] The specified session has been 
invalidated for some reason.) boot: (:priority NORMAL:%DUMBFW :hostname :loglevel 0 :min-prime-bits nil :trustfiles 
(/etc/ssl/certs/ca-certificates.crt) :crlfiles nil :keylist nil :verify-flags 
nil :verify-error nil :callbacks nil)

It might be essentially the same information, so I won't post any of the other 
messages I get when clicking on other packages. 

Thanks all for your help - hopefully this is useful!


-----Original Message-----
From: Philip Kaludercic <> 
Sent: Wednesday, October 13, 2021 10:32 AM
To: Janelle Rose <>
Cc: Akber Khan <>; Tassilo Horn <>;
Subject: Re: Issues installing packages from melpa

Janelle Rose <> writes:

> We do have a lot of customizations to our emacs install. Is there a 
> way to launch a "vanilla" version to ignore those customizations.

Yes, you add a -Q argument to Emacs like so:

     emacs -Q

        Philip Kaludercic

reply via email to

[Prev in Thread] Current Thread [Next in Thread]