[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[help-gnubatch] GNU Batch build failure.

From: Rg Glpj
Subject: [help-gnubatch] GNU Batch build failure.
Date: Wed, 12 Sep 2012 13:40:26 -0700 (PDT)


I am trying to build GNU Batch version 1.6 on Windows box using Cygwin. I have overcome the preliminary issues with shared memory management and library dependency. When I run it is failing to compile one file after running for a while. For my layman eyes it looks to be a dependency issue or perhaps a forward declaration is required in gprompt.c. Need your expert guidance, would someone please help? 

I even tried "make clean; make" that did not help. Also, looked up mailing list archives no one seem to have encountered the issue.

libtool --mode=link gcc -O -g -Wall -fno-stack-protector  -o gbch-cichange  btcichange.o lib/ lib/
libtool: link: gcc -O -g -Wall -fno-stack-protector -o .libs/gbch-cichange btcichange.o  lib/.libs/libgnubatch_int.a lib/.libs/libgnubatch_client.a
gcc -O -g -Wall -fno-stack-protector  -Ihdrs -I..   -c -o btcilist.o btcilist.c
libtool --mode=link gcc -O -g -Wall -fno-stack-protector  -o gbch-cilist  btcilist.o lib/ lib/
libtool: link: gcc -O -g -Wall -fno-stack-protector -o .libs/gbch-cilist btcilist.o  lib/.libs/libgnubatch_int.a lib/.libs/libgnubatch_client.a
lib/.libs/libgnubatch_client.a(gprompt.o): In function `gprompt':
/cygdrive/c/temp/gnubatch/gnubatch-1.6/build/lib/gprompt.c:28: undefined reference to `_helpprmpt'
collect2: ld returned 1 exit status
Makefile:108: recipe for target `gbch-cilist' failed
make[1]: *** [gbch-cilist] Error 1
make[1]: Leaving directory `/cygdrive/c/temp/gnubatch/gnubatch-1.6/build'
Makefile:53: recipe for target `build-src' failed
make: *** [build-src] Error 2


reply via email to

[Prev in Thread] Current Thread [Next in Thread]