[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [help-gnubatch] GNU Batch build failure.

From: John Collins (Xi Software Ltd)
Subject: Re: [help-gnubatch] GNU Batch build failure.
Date: Wed, 12 Sep 2012 23:51:48 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/20120827 Thunderbird/15.0

On 12/09/12 21:40, Rg Glpj wrote:

I am trying to build GNU Batch version 1.6 on Windows box using Cygwin. I have overcome the preliminary issues with shared memory management and library dependency. When I run it is failing to compile one file after running for a while. For my layman eyes it looks to be a dependency issue or perhaps a forward declaration is required in gprompt.c. Need your expert guidance, would someone please help? 

I even tried "make clean; make" that did not help. Also, looked up mailing list archives no one seem to have encountered the issue.

libtool --mode=link gcc -O -g -Wall -fno-stack-protector  -o gbch-cichange  btcichange.o lib/ lib/
libtool: link: gcc -O -g -Wall -fno-stack-protector -o .libs/gbch-cichange btcichange.o  lib/.libs/libgnubatch_int.a lib/.libs/libgnubatch_client.a
gcc -O -g -Wall -fno-stack-protector  -Ihdrs -I..   -c -o btcilist.o btcilist.c
libtool --mode=link gcc -O -g -Wall -fno-stack-protector  -o gbch-cilist  btcilist.o lib/ lib/
libtool: link: gcc -O -g -Wall -fno-stack-protector -o .libs/gbch-cilist btcilist.o  lib/.libs/libgnubatch_int.a lib/.libs/libgnubatch_client.a
lib/.libs/libgnubatch_client.a(gprompt.o): In function `gprompt':
/cygdrive/c/temp/gnubatch/gnubatch-1.6/build/lib/gprompt.c:28: undefined reference to `_helpprmpt'
collect2: ld returned 1 exit status
Makefile:108: recipe for target `gbch-cilist' failed
make[1]: *** [gbch-cilist] Error 1
make[1]: Leaving directory `/cygdrive/c/temp/gnubatch/gnubatch-1.6/build'
Makefile:53: recipe for target `build-src' failed
make: *** [build-src] Error 2

I have to say I have never attempted or even thought about building it on a Windows box.

The whole thing was designed around Unix systems. I don't even know whether whole swathes of code will work.

Your problem is probably because it is relying on finding ranlib or equivalent although the Makefile does try to build them in a "topologically sorted" order.

I fear you are on your own a bit here - sorry.

John Collins address@hidden Xi Software Ltd

Phone: +44 (0)1707 886110 Home Phone: +44 (0)1707 883174
Mobile: +44 (0)7958 387247 (address@hidden)

Trading Address 3 Mandeville Rise, Welwyn Garden City, Herts, AL8 7JT, UK

Registered in England Company Number 01977148 VAT GB 403 9239 64 R/O: 2 Mill Road, Haverhill, Suffolk, CB9 8BD

reply via email to

[Prev in Thread] Current Thread [Next in Thread]