[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: route learning

From: t3sserakt
Subject: Re: route learning
Date: Mon, 1 Aug 2022 11:39:03 +0000

On 31.07.22 18:00, wrote:


Message: 1
Date: Sun, 31 Jul 2022 11:30:04 +0200
From: ToBo <>
To: Help-gnunet <>
Subject: Re: route learning
Message-ID: <>
Content-Type: text/plain;       charset=us-ascii


29 juli 2022 kl. 22:58 skrev Martin Schanzenbach <>:
Excerpts from ToBo's message of 2022-07-29 14:23:48 +0200:
I set up a three nodes in a very simple configuration: A and B is behind NAT, 
so they both have to communicate with each other through C

A   ->   C   <-   B

All nodes are in friend only mode. All nodes have some knowledge of each other, at least you can 
see infos in "gnunet-peerinfo" or "gnunet-peerinfo -f" (what is the exact 
difference anyway?)
Do you have any actual connections?
Try with "gnunet-core".
I mainly used gnunet-transport to monitor that, but yes, gnunet-core
has shown the same.

Why does a gnunet-cadet don't find it's way from A to B ?
This may be due to many reasons. Try compiling gnunet with
"--enable-logging=verbose" and set the debug level for cadet to DEBUG.
Then check logs.
That would be my first approach (IF you have connections at all see
I recompiled it and tried again, this time it worked for whatever
reason. Sometimes the behavior of GNUnet is hard to understand.

How can I configure a minimal set of deamons to just have a network or session
layer with cadet? I think this will help in understanding the whole thing.

Each service can have a section in the configuration file, if you like to change the default values.

You can have a look onto the default values in the source code. For example to look for the default values of the file sharing service you might have a look into the file


There you see at the very beginning


If you change IMMEDIATE_START to NO. This service will not start when starting the GNUnet peer, but if it is needed. If you change START_ON_DEMAND to NO it will not start at all.

- t3sserakt

Attachment: OpenPGP_0x524982A0100F7490.asc
Description: OpenPGP public key

Attachment: OpenPGP_signature
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]