[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem building gnustep-gui

From: cga
Subject: Re: Problem building gnustep-gui
Date: Wed, 09 Jan 2002 20:41:10 -0500

Nicola Pero wrote:

> >    GNUSTEP Internal Error:
> >    The private GNUstep function to establish the argv and environment
> >    variables was not called.
> >    Please report the error to
> >
> >    Uncaught exception NSInternalInconsistencyException, reason:
> >    GNUSTEP Internal Error:
> >    The private GNUstep function to establish the argv and environment
> >    variables was not called.
> >    Please report the error to
> This is normally caused by a configuration problem when configuring
> gnustep-base.
> Check the output of ./configure when run in gnustep-base ... you want to
> look for the following stuff -
> checking if +load method is executed before main... yes
> checking kernel support for /proc filesystem... yes
> checking use of fake-main definition... no
> The fact you're using RH 7.1 might be the problem ... if it includes a gcc
> 2.96.x compiler, that doesn't work, you need to install gcc 3.0.3 and use
> it (look on the gnu.gnustep.discuss mailing list (or newsgroup) archives
> for a discussion of how to install and use it with gnustep.


Thanks for your reply. I was accessing the mailing list via the
newsgroup mirror and was missing a lot on the action. Thought
my original post had bounced. Have now subscribed to the ML.

Following a one-step-at-a-time strategy I switched from a
physical machine (quite a shambles..) to doing the install
under vmware so I have a 'clean' & disposable Red Hat
to work with.

Since I had read another post hinting at possible problems
with the 2.96.x gcc compiler I had initially tried upgrading
to gcc 3.0.3 as you recommend but encountered diverse
problems with the GNUstep install. I was not sure how to
address these problems because I was not 100% that I
was really using a 'clean' 3.0.3 environment. But that
was with the messed-up test machine and I haven't tried
it yet on a clean VM.

My first attempt on a VM was with some rpm's that I found
- on a 'www..peanuts..' site I believe - and was fairly
successful. I had to install the libwraster & Hermes libs
to keep rpm happy but otherwise the install per se was
plain sailing..

I then installed the latest Window maker (8.0) and ended up
with a bunch of GS environment variables automatically
initialized every time I start a shell. I found an Apps directory
under $GS_SYSTEM_ROOT that contained a bunch of wrappers
for  standard applications (vi, xemacs etc..) and was able to
launch them - openapp app - but obviously didn't notice much
difference with regular versions of the same dressed up by
Window Maker.

I proceeded to install some specific GNUstep apps such as
GSCommander & GWorkspace and they appeared to
install successfully but failed when I tried to launch them:

   [gavron@vmw25 /root]# openapp
   error: NXConstantString (instance)
   NXConstantString does not recognize getCharacters:
   /usr/GNUstep/System/Tools/openapp: line 100: 20984 Aborted
           (core dumped) $full_appname/$appname $@


At this point I am pretty much ready for another attempt:

1. Recreate the virtual machine - probably with RH 7.2 - still
   has the gcc 2.96.x compiler but I might as well be current

2. Upgrade the compiler & lib's following your recommendations

3. Install GNUstep paying closer attention to the ./configure step

4. Install a few applications.

Aspects I still feel a little shaky about:

1. Making sure the gcc upgrade is consistent. I saw they
    have a test suite and wonder if that could help.

2. I noticed in various places that there are some boot-time
    services that I need to set up but they seem to be mainly
    related to running GS apps over a network. My understanding
    is that I won't need them for a single machine.

3. Choosing the GNUstep packages that are more likely to
    install without problems on RH 7.2. This is what I have


    From what I have read only the first four tarballs are really
    necessary for a trial install.

I aplogize for all these details.. You may spot something
obvious that I'm missing. Or suggest a different approach.

Thanks again for your help.



PS. Hope I'm sending this reply to the right addresses..

reply via email to

[Prev in Thread] Current Thread [Next in Thread]