[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: addresse in System Domain

From: Eric Heintzmann
Subject: RE: addresse in System Domain
Date: Tue, 10 Feb 2004 23:32:37 +0100

On jeu, 2004-02-05 at 23:26, Adam Fedor wrote:
> > -----Original Message-----
> > From: Eric Heintzmann
> > 
> > Oh yes that helps me :
> > Now addresses manager seems to work fine. ( There are still these
> > messages :
> > AddressManager[2269] Problem locating framework Addresses
> > AddressManager[2269] Problem locating framework AddressView
> > )
> > 
> I think that this can be solved, if you are installing in a different place 
> than the default, by compiling with GNUSTEP_INSTALLATION_DIR set:

Since I am not installing Addresses but I m packaging it, I've tried


But that didn't work, then I also tried to set
but of course that didn't work.

Finally I decided to use symlinks for this release.
I will change that later.

But I've also found another problem.
Files in French.lproj and German.lproj (in AddressManager,
Frameworks/Addresses and Frameworks/AddressView subdirectories) make
dpkg crash when dpkg tries to unpack them (yes, crash, never seen that
I ve tried to change encoding but that didn't work.
So, I've got a question :
What encoding these file should use ? UTF-8 ?

For this release, I've removed all French.lproj and German.lproj dirs.

> I've also found a bug in gnustep-base that prevented GNUstep from using a 
> more robust method of finding the framework location. I'll commit that 
> shortly.  After that change everything works for me and I don't have to make 
> any extra links anywhere.

I would like to do a suggestion for Addresses :

Add some GNUmakefile.preamble files in Goodies subdirectories, to allow
building goodies without installing all frameworks.
This is not really needed for normal users but it would make life of
maintainers easier.
See attached .diff file


Attachment: addresses.diff
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]