[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cannot find interface declaration for `NXConstantString'

From: Carlo Salinari
Subject: Re: cannot find interface declaration for `NXConstantString'
Date: Tue, 13 Apr 2004 21:32:04 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040401 Debian/1.6-4

Adam Fedor wrote:

On Tuesday, April 13, 2004, at 10:52 AM, Carlo Salinari wrote:

Hello list,

Apologies, for this is a known issue (consulted the archives and googled),
but I'm stuck.

I keep getting the infamous error:

*cannot find interface declaration for `NXConstantString'*

with every source I try to compile.

I'm running i386-debian testing/unstable.
gcc 3.3.3
gnustep-base1 1.9.0-4
gnustep-base1-dev 1.9.0-4

Commands I've run to install the thing:

apt-get install gnustep-base1 gnustep-base1-dev
(this throws in packet gobjc-3.3)

Any hint for this wannabe objc programmer?

Are these your own programs or some known working examples?
Can you send the output of make for one of these programs? Be sure to use

make messages=yes

to get all the information.

Well, tested some in "gnustep-base-1.9.1/Testing" from the latest tarball.
My best bet was this:

gcc -lobjc -I/usr/lib/GNUstep/System/Library/Headers string.m

but evidently I'm missing something about what headers/libs objc looks for.

Just now I've tried to compile guestep-base from the sources, and it worked (after
having done ". Makefiles/", so probably there's something whith
my env variables too).

I'm getting frustrated... :-)

Thanks for answering,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]