[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Installation Woes

From: Wayne Stewart
Subject: Installation Woes
Date: Fri, 27 Aug 2004 18:37:25 +1000


Sorry to hassle everyone but I can't seem to make the installer work.

I have got Mandrake 10.

I have been following the build guide at:

The quoted sections below are from the guide.


My system passed all the tests except the following:

> Foreign Function Interfaces
> Priority: A must have
> Here you have the option to use the ffi library that comes with GCC or 
> to use ffcall. It's up to you.
> gcc
>    Which should return:
> 2.0.0
>  or higher.

In my case it returns:

I assume this means that I don't have the required library

There appears to be an alternative called:

> ffcall
> No way to check in a simple way.

I downloaded ffcall-1.10.tar.gz and extracted it and installed it with 
no error messages.  So presumably I have got around that problem (but I 
think that is my hiccough)

Building  -  Part One gnustep-make

I then downloaded gnustep-make-1.9.2.tar.gz and installed it according 
to these instructions:

> gnustep-make

>This package sets up the GNUstep directory tree, sets some environment 
> variables and contains scripts for all other packages installed hereafter.
> 1.
>      Download
> gnustep-make-1.8.0.tar.gz

NB I have downloaded a more recent version 1.9.2

>  2.
>     Build

> ./configure --prefix=/usr/GNUstep
> make
> make install


>   3.
>     Post-install

>     If you are using Bourne Shell (/bin/sh), Korn Shell (/bin/ksh), 
>     or the Bourne Again Shell (/bin/bash), type:
>    . /usr/GNUstep/System/Makefiles/

I tried this but it didn't work.  I looked at the folders involved and saw that 
there had been some changes in the path on my machine the path was:  

So I ran the command:

     . /usr/GNUstep/System/Library/Makefiles/

Nothing visible appeared to happen - but with the other version an error was 
reported (no directory or something like that.

Building  -  Part Two gnustep-base

>    It provides functionality that aims to implement the non-graphical 
> portion of the OpenStep standard (the Foundation library).
>FreeBSD: If you installed libxml2 through ports, make sure that you 
> change in the gnustep-base the configure script. It should include -lgiconv.
>   1.
>      Download
> gnustep-base-1.8.0.tar.gz

NB I downloaded gnustep-base-1.9.2.tar.gz instead, but otherwise followed 

>   2.
>      Build

There were no error messages but examining the out put I found the following.  
I have no idea if it is significant or not.

>checking ffi.h usability... no
>checking ffi.h presence... no
>checking for ffi.h... no
>checking callback.h usability... yes
>checking callback.h presence... yes
>checking for callback.h... yes
>checking "for forwarding callback in runtime"... yes
>checking "FFI library usage"... ffcall

I then ran Make

Somethings appear to compile OK (occasionally there are some warnings but it 
still keeps working) but at the end I get this message:

make[2]: Leaving directory `/mnt/win_e/Extract/gnustep-base-1.9.2/Tools/make    
make[1]: Leaving directory `/mnt/win_e/Extract/gnustep-base-1.9.2/Tools'
Making all in NSCharacterSets...
make[1]: Entering directory `/mnt/win_e/Extract/gnustep-base-1.9.2/NSCharact    
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/mnt/win_e/Extract/gnustep-base-1.9.2/NSCharacte    
Making all in NSTimeZones...
make[1]: Entering directory `/mnt/win_e/Extract/gnustep-base-1.9.2/NSTimeZon    
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/mnt/win_e/Extract/gnustep-base-1.9.2/NSTimeZone    
Making all in Resources...
make[1]: Entering directory `/mnt/win_e/Extract/gnustep-base-1.9.2/Resources    
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/mnt/win_e/Extract/gnustep-base-1.9.2/Resources'

I presume these are error messages?

I then attempt to do install:

>make install

      If you are using C-Shell (/bin/csh), the T-C-Shell (/bin/tcsh), type:

source /usr/GNUstep/System/Makefiles/GNUstep.csh



An intelligent man is sometimes forced to be drunk to spend time with 
-- Ernest Hemingway (For Whom The Bell Tolls)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]