[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Installation Woes

From: Nicola Pero
Subject: Re: Installation Woes
Date: Fri, 27 Aug 2004 11:30:44 +0100 (BST)

> Hi,
> Sorry to hassle everyone but I can't seem to make the installer work.
> I have got Mandrake 10.
> I have been following the build guide at: 

My main comment is ... it's simpler than it looks :-)

> I downloaded ffcall-1.10.tar.gz and extracted it and installed it with 
> no error messages.  So presumably I have got around that problem (but I 
> think that is my hiccough)

Looking at the output of gnustep-base below, yes I think that worked :-)

Keep in mind that for those prerequisites you need, there might be an .rpm
package for Mandrake 10 (in your CDs already or somewhere on the net)
which you can install without having to compile stuff.

Anyway, you already installed ffcall.

> >     Post-install
> >     If you are using Bourne Shell (/bin/sh), Korn Shell (/bin/ksh), 
> >     or the Bourne Again Shell (/bin/bash), type:
> >
> >    . /usr/GNUstep/System/Makefiles/
> I tried this but it didn't work.  I looked at the folders involved and
> saw that there had been some changes in the path on my machine the path
> was:  /usr/GNUstep/System/Library/Makefiles
> So I ran the command:
>      . /usr/GNUstep/System/Library/Makefiles/
> Nothing visible appeared to happen - but with the other version an error
> was reported (no directory or something like that.

Well - yes it seems you did a good job infact the path you've used is the
right one.  Maybe you want to tell dennis about the bug in the build

The visible difference is that some environment variables such as
GNUSTEP_SYSTEM_ROOT should be defined after you execute the script, eg try


before and after sourcing the script

> >./configure
> There were no error messages but examining the out put I found the following. 
>  I have no idea if it is significant or not.
> >checking ffi.h usability... no
> >checking ffi.h presence... no
> >checking for ffi.h... no
> >checking callback.h usability... yes
> >checking callback.h presence... yes
> >checking for callback.h... yes
> >checking "for forwarding callback in runtime"... yes
> >checking "FFI library usage"... ffcall

Sounds Ok

> I then ran Make
> >make
> Somethings appear to compile OK (occasionally there are some warnings but it 
> still keeps working) but at the end I get this message:
> make[2]: Leaving directory `/mnt/win_e/Extract/gnustep-base-1.9.2/Tools/make  
>                                          _strings'
> make[1]: Leaving directory `/mnt/win_e/Extract/gnustep-base-1.9.2/Tools'
> Making all in NSCharacterSets...
> make[1]: Entering directory `/mnt/win_e/Extract/gnustep-base-1.9.2/NSCharact  
>                                             erSets'
> make[1]: Nothing to be done for `all'.
> make[1]: Leaving directory `/mnt/win_e/Extract/gnustep-base-1.9.2/NSCharacte  
>                                             rSets'
> Making all in NSTimeZones...
> make[1]: Entering directory `/mnt/win_e/Extract/gnustep-base-1.9.2/NSTimeZon  
>                                             es'
> make[1]: Nothing to be done for `all'.
> make[1]: Leaving directory `/mnt/win_e/Extract/gnustep-base-1.9.2/NSTimeZone  
>                                             s'
> Making all in Resources...
> make[1]: Entering directory `/mnt/win_e/Extract/gnustep-base-1.9.2/Resources  
>                                             '
> make[1]: Nothing to be done for `all'.
> make[1]: Leaving directory `/mnt/win_e/Extract/gnustep-base-1.9.2/Resources'
> I presume these are error messages?

No - they look like Ok to me.  Resources don't need to be built, only to
be installed, that's why it says "Nothing to be done for 'all'".

> I then attempt to do install:
> >make install

And yes ... ?

All seems nice up to now.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]