[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

MacOSX GNUstep build issues

From: Kree Cole-McLaughlin
Subject: MacOSX GNUstep build issues
Date: Wed, 08 Dec 2004 15:45:09 -0800
User-agent: Mozilla Thunderbird 0.9 (Macintosh/20041103)

I have somewhat successfully built GNUstep on my mac running system 10.3.6, but I am having some problems running apps. I was hoping someone could help me figure out if something went wrong in the build or if I need to setup something differently. First of all here is how I built things:

I started by build gcc-3.4.3 enabling posix threads, the languages c and objc, and objc-gc with boehm-gc. I intsalled this in /GNUstep/usr so as to make it a part of my /GNUstep environment.

Next I built the /GNUstep packages with gnu-gnu-gnu library combo and /GNUstep root directory. During the build of some of the base, gui, and back tools I had to explicitly add libraries to the makefiles since I only have static versions of several libs like jpeg, tiff, xml, etc... These libs were installed by fink, so I am not sure why they weren't compiled as shared libs.

Finally, I built Gorm. Again I had to explicitly link against all these static libs.

Now when I try to run openapp, a window pops-up and says "Could not load pallette class", after clicking OK several times I get the following error on my command line:

2004-12-08 15:02:56.000 Gorm[3988] Bad palette selection - -1
2004-12-08 15:02:57.000 Gorm[3988]
I couldn't contact the notification server for local host -
so I'm attempting to to start one - which will take a few seconds.
Trying to launch gdnc from /GNUstep/System/Tools or a machine/operating-system subdirectory.
It is recommended that you start the notification server (gdnc) either at
login or (better) when your computer is started up.
Bus error

Note that the first time I tried this it was about gdomap (instead of gdnc), so I launched /GNUstep/System/Tools/gdomap. The next time I tried openapp I got the above error. But when I try to launch /GNUstep/System/Tools/gdnc and rerun Gorm I get the same error. Upon inspecting my processes gdomap is running but not gdnc.

Do I need to have several daemons running to launch GNUstep apps? If so which ones. Does this means gdnc was not built correctly? (I don't get any errors when I launch it)
Any suggestions about how to get things running.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]