[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: MacOSX GNUstep build issues

From: Adam Fedor
Subject: Re: MacOSX GNUstep build issues
Date: Wed, 8 Dec 2004 21:41:35 -0700

On Dec 8, 2004, at 4:45 PM, Kree Cole-McLaughlin wrote:
Next I built the /GNUstep packages with gnu-gnu-gnu library combo and /GNUstep root directory. During the build of some of the base, gui, and back tools I had to explicitly add libraries to the makefiles since I only have static versions of several libs like jpeg, tiff, xml, etc... These libs were installed by fink, so I am not sure why they weren't compiled as shared libs.

Usually -dev packages install the static libs and the includes, while the base packages install the shared libs. I didn't think it was possible to install the -dev packages without the base package, but perhaps you figure it out...

Note that the first time I tried this it was about gdomap (instead of gdnc), so I launched /GNUstep/System/Tools/gdomap. The next time I tried openapp I got the above error. But when I try to launch /GNUstep/System/Tools/gdnc and rerun Gorm I get the same error. Upon inspecting my processes gdomap is running but not gdnc.

Do I need to have several daemons running to launch GNUstep apps? If so which ones. Does this means gdnc was not built correctly? (I don't get any errors when I launch it)
Any suggestions about how to get things running.

This should be done automatically if you don't do it. But for testing, you should do it manually:


Then test to see that gdnc started running using:

gdomap -N

which should give:

Registered names are -

You don't specify what version of GNUstep base,gui, etc you are using. Also did you follow the README.Darwin instructions when installing this?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]