[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: MacOSX GNUstep build issues

From: Kree Cole-McLaughlin
Subject: Re: MacOSX GNUstep build issues
Date: Thu, 09 Dec 2004 01:19:07 -0800
User-agent: Mozilla Thunderbird 0.9 (Macintosh/20041103)

Adam Fedor wrote:

On Dec 8, 2004, at 4:45 PM, Kree Cole-McLaughlin wrote:

Next I built the /GNUstep packages with gnu-gnu-gnu library combo and /GNUstep root directory. During the build of some of the base, gui, and back tools I had to explicitly add libraries to the makefiles since I only have static versions of several libs like jpeg, tiff, xml, etc... These libs were installed by fink, so I am not sure why they weren't compiled as shared libs.

Usually -dev packages install the static libs and the includes, while the base packages install the shared libs. I didn't think it was possible to install the -dev packages without the base package, but perhaps you figure it out...

Ooops, you're right, I got it backwards. I guess libgnustep-base is linking agaisnt the shared libraries, which means every time I want to build an app I need to include the libraries in the linking command (what a pain!) Does anyone know how to force darwin to include the static versions of the libraries in libgnustep-base? Do I have to move the shared libraries out of the way while I compile GNUstep? There should be a better way.

Note that the first time I tried this it was about gdomap (instead of gdnc), so I launched /GNUstep/System/Tools/gdomap. The next time I tried openapp I got the above error. But when I try to launch /GNUstep/System/Tools/gdnc and rerun Gorm I get the same error. Upon inspecting my processes gdomap is running but not gdnc.

Do I need to have several daemons running to launch GNUstep apps? If so which ones. Does this means gdnc was not built correctly? (I don't get any errors when I launch it)
Any suggestions about how to get things running.

This should be done automatically if you don't do it. But for testing, you should do it manually:


Then test to see that gdnc started running using:

gdomap -N

which should give:

Registered names are -

Okay, gdomap -N say nothing is registered. I guess this means there is a problem with gdnc right?

You don't specify what version of GNUstep base,gui, etc you are using. Also did you follow the README.Darwin instructions when installing this?

I did follow the README.darwin instructions during the build, but I didn't read about the daemons until after I sent this. I checked the source out of CVS probably a week ago, so I don't know what the exact versions are. Would you suggest I compile a stable release instead?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]