[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

installing gnustep-base fails on openbsd (cannot find ffcall)

From: Sebastian Reitenbach
Subject: installing gnustep-base fails on openbsd (cannot find ffcall)
Date: Fri, 31 Mar 2006 12:33:40 -0000


I have running on openbsd now for more than half a year. But 
I lack a development environment. I heard about projectcenter, so wanted to 
try that out. OGo comes along with a gnustep-make and base of version 1.11.
project center requires 1.12.

I tried to use the gnustep-start, to install gnustep, and also the packages on 
their own. I installed ffcall as described here:

I also installed a version from ports. without any luck.

the ./configure of gnustep-base fails with the following error:

checking link to exe of process in /proc... no
checking /proc/29225/cmdline terminated by nul... no
checking for kvm_getenvv in -lkvm... yes
checking if we can access kernel memory... no
checking "use of pass-through arguments"... no
checking "use of fake-main definition"... yes
checking ffi.h usability... yes
checking ffi.h presence... yes
checking for ffi.h... yes
checking callback.h usability... yes
checking callback.h presence... yes
checking for callback.h... yes
checking "for forwarding callback in runtime"... no
checking "FFI library usage"... none

You do not have an up-to-date libobjc library installed
GNUstep requires ffcall or libffi and proper libobjc hooks to do
invocations and DO.
(This does not apply on apple-apple-apple systems where DO is
not compatible with other GNUstep systems.)

You most likely do not want to build base without DO support. Many
things, including all applications, won't work at all without DO.
If you really want to build -base without DO support, add --disable-do
to the configure arguments.
For more information, read the GNUstep build guide, ffcall section:
configure: error: Incomplete support for ffi functionality.
Installation of GNUstep Base failed. Send 
the /usr/local/src/gnustep/gnustep-startup-0.15.0/build/logs.tar.gz
file to for help

I can send the logs.tar.gz if that will help. The link in the error output to 
how to installffcall did not worked, so I used the other above mentioned link.

Anybody with more insight can help out? I cannot believe it is impossible as I 
have the opengroupware running.

so long, 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]