[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: pl2link error while installing application? [MacOS problem: SOLVED]

From: Daniel J Farrell
Subject: Re: pl2link error while installing application? [MacOS problem: SOLVED]
Date: Wed, 7 Jun 2006 02:03:17 +0100

Hi Adam,


Thanks for the link ( User/GNUstep/userfaq_1.html#SEC25) I didn't notice that this info was available. The problem does seem to be that when acting as sudo to install everything (as I have) the dynamic library path is cleared (for security reasons)!

The evidence for this is shown below (at the end).

That said could somebody clarify the advice given in the documentation (above link) as how to solve this problem when it says:

'...If you are becoming root to install something, you need to exec the file as root, just as you do when you login. Although for simplicity, you can also try this:

1) Does executing via the .profile run the script as root during startup?
2) What does the make line do?

By the way on MacOS the dynamic library path variable is actually, DYLD_LIBRARY_PATH not LD_LIBRARY_PATH.

Conclusion (for future problems like this)

To get this to work I firstly changed to root (NOT sudo but root!):

Daniel$ sudo bash

I then entered the line as suggested (changed for MacOS by prefixing the 'DY'):


then went, make and make install.

root# make
root# make install

Finally, I quit the terminal. Opened X11 window. Re-opened the terminal and typed:

Daniel$ openapp Affiche

Kind regards and many thanks for your help folk!


PS - terminal cut and pastes

---terminal snippet #1 running as user---
/Users/Daniel/GNUstep/Library/Libraries:/opt/local/GNUstep/Local/ Library/Libraries:/opt/local/GNUstep/System/Library/Libraries

---terminal snippet #2 running as root---
Daniel$ sudo bash

i.e. nothing!!

On 6 Jun 2006, at 21:05, Adam Fedor wrote:

That's probably due to this problem: userfaq_1.html#SEC25

On Jun 6, 2006, at 2:00 PM, Daniel J Farrell wrote:

Hi everyone,

Almost there now, I have Affiche compiled and running locally! That is to say the 'sudo make' command got far enough to compile everything fine so that I can run the app from it's directory:

openapp ./

However when ever I try to 'make' I'm still getting this strange error pl2link error/ dynamic library not loading (see below). Has anybody else here installed this using DarwinPorts. gnustep is a great environment I'd love to start using it.


PS - here is the error I get when I try to sudo make an app:

Daniel$ ~/Desktop/gnustep/Affiche Daniel$ sudo make

Making all for app Affiche...
dyld: Library not loaded: libgnustep-base.dylib.1.12
  Referenced from: /opt/local/GNUstep/System/Tools/pl2link
  Reason: image not found
make[1]: *** [] Error 133
make: *** [] Error 2

On 6 Jun 2006, at 06:00, Adam Fedor wrote:

Well, localhost0:0:0 isn't a valid display name. It should be something like hostname:#.#


or even


should almost always work on a local display. I wonder how you display name got set to that?
to set:

export DISPLAY=:0.0

On Jun 5, 2006, at 4:28 PM, Daniel J Farrell wrote:

Hi Fred,

Yeah it's kind of encouraging! Now after running X11 (I assume all I have to do is open the X11 terminal) first I get a message saying:

fatal error: could not open display localhost0:0:0

So should be a simple case of just setting this correctly. I haven't been able to find what to set this too for mac os; any ideas?


On 5 Jun 2006, at 19:45, Fred Kiefer wrote:

This looks much better than I did expect. Most likely you just did
forget to start the X server here.

But where does the pl2link problem then come from?


Daniel J Farrell schrieb:

The result is what looks like a windowing system error (see below).

Does this mean that everything is working but I just need to set the
display variable?


PS - Result from running the app locally:

~/Desktop/gnustep/Affiche Daniel$ openapp ./

_X11TransSocketINETConnect() can't get address for localhost0:0:6000: No
address associated with nodename
/Users/Daniel/Desktop/gnustep/Affiche/ Uncaught exception WindowServerCommunication, reason: Unable to connect to X
Server `localhost0:0:0'

Help-gnustep mailing list

Help-gnustep mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]