[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Runtime relocation problem with gnustep

From: Warren Nagourney
Subject: Runtime relocation problem with gnustep
Date: Wed, 13 Dec 2006 19:32:27 -0800
User-agent: Mail/News 1.5 (X11/20051201)

I posted a copy of this on the "discuss" forum; perhaps this is the better place for help. I successfully installed gnustep in YDL 4.1 on my Powerbook 17 using the very useful script available at the site. After remedying a few problems (lack of obj-C and its libraries in the usual YDL installation) it installed fine. When I tried to install the most useful app - GWorkspace - I kept getting errors of the "R_PPC_REL24 relocation" variety, indicating that variables were out of reach using pc-relative addressing modes. I then added -fPIC (position independent code) to all of the makefiles (after running configure) and still get these errors. I am tearing my little remaining hair out. Can someone please help me? Here is a copy of the error message (I have gotten this message with other apps that I compiled - same library, libgnustep-gui...):

[root@localhost gnustep-startup-0.16.0]# openapp GWorkspace
/usr/GNUstep/System/Applications/ error while loading shared libraries: /usr/GNUstep/System/Library/Libraries/ R_PPC_REL24 relocation at 0x0fd6559c for symbol `pow' out of range
[root@localhost gnustep-startup-0.16.0]#

Actually, doing a grep of all of the files in the source directory displayed an absence of "-fPIC". How do I make sure this is being used for compilation?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]