[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNUStep under Windows

From: Fred Kiefer
Subject: Re: GNUStep under Windows
Date: Fri, 29 Feb 2008 17:32:26 +0100
User-agent: Thunderbird (X11/20070801)

Darin Bray wrote:
> Warning...I am a complete newbie.  I am trying to learn how to program
> Objective-C.  My ultimate goal is to code for the Mac, but unfortunately
> my only Mac is my home machine which I get very little time to work on. 
> As a result I was trying to setup my Windows laptop to use GNUStep so I
> could work on my programs more often.  I have tried installing GNUStep
> several ways, and have not had any success.  I tried the method using
> MingW (I already had this installed for compiling C programs).  This
> didn't work as I was unable to get all of the pieces downloaded for
> GNUStep.  I ended up downloading the Core and System Windows installers
> from the GNUStep website.  These installed fine, and appear to have all
> the pieces.  However I am still unable to compile a program.  I believe
> my problem lies in the include directories for my headers and
> libraries.  Could someone who is using this setup give me an example of
> their gcc command line to build an application.
> Thanks in advance for the help
> Darin

This isn't much information that you are giving about your problem. Are
you trying to compile an Objective-C project without a GNUmakefile? In
that case better read up about our make system and grab some example
project from the GNUstep pages (any application will do).

Or is your problem as easy as forgetting to source the file
before running make?

If you have further problems wiht GNUstep on Windows you could check out
the mail I send to the GNUstep discussion list by the end of last year.
That was when I first tried the new installer and had some problems myself.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]