[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: printf: doens't print on WinXP installation

From: Adam Fedor
Subject: Re: printf: doens't print on WinXP installation
Date: Fri, 23 Oct 2009 08:44:34 -0600

Oh, yes - you are trying to compile this as an Application. In that case, GNUstep adds some special flags to keep Windows from trying to output stuff to a command window. If you really want to see the output of printf, you'll have to compile it as a tool:

include $(GNUSTEP_MAKEFILES)/tool.make

or you could use NSLog (but that goes to the Windows system log unless you are using gdb).

On Oct 22, 2009, at 8:23 PM, jacksk58 wrote:

I'm runnuning this on an XP installation. I'm supplying - hello.m,
GNUmakefile and the text from the GNUStep Shell


#import <stdio.h>

int main( int argc, const char *argv[] ) {
   printf( "hello world\n" );

   return 0;

include $(GNUSTEP_MAKEFILES)/common.make

APP_NAME = HelloWorld
HelloWorld_OBJC_FILES = hello.m

include $(GNUSTEP_MAKEFILES)/application.make

GNUStep Shell 'Screen Shot'
Setting up GNUstep Environment...

kj@CR ~
$ make
This is gnustep-make 2.2.0. Type 'make print-gnustep-make-help' for help.
Making all for app HelloWorld...
Compiling file hello.m ...
Linking app HelloWorld ...
Creating library file: ./
Creating stamp file...

kj@CR ~
$ openapp ./

kj@CR ~

Richard Frith-Macdonald-2 wrote:

On 22 Oct 2009, at 00:52, jacksk58 wrote:

I am running into the same problem as Alex Bilyk.  -- "printf:
doens't print
on WinXP installation", when compiled by GNUmakefile. It works, when
compliled, without the makefile. I like compliling by GNUmakefiles.
someone tell me why, printf("hello, world") doesn't work when
complied by
GNUmakefiles. I'm only curious about the problem with Printf.


Alex Bilyk wrote:


Just installed GNUstep on Win XP. Doing the simplest of things with
a main
function that has printf("hello, world"); in it. Everything
compiles and
runs, except there is no output to the console. I can step through
code in
dgb and it goes over this line fine. A bit of a puzzle. Tried to use
NSLog(@"..."); version - same result.  App is built and run
but with no printout to the console. Any ideas? BTW, stepping in
gdb over
the NSLog version has some issues that the printf version doesn't
but that's a separate topic. I'm really after the printout at the
as you might imagine:)


I think it might help to have the code and the makefile to see if
anyone can reproduce this ... printf works fine for me.

Help-gnustep mailing list

View this message in context:
Sent from the GNUstep - Help mailing list archive at

Help-gnustep mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]