[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-gnutls] opencdk build error?

From: Pete Naylor
Subject: Re: [Help-gnutls] opencdk build error?
Date: Mon, 3 Nov 2003 13:05:57 -0800
User-agent: Mutt/1.4.1i

John Lodder wrote...

> I'm trying to build opencdk on Solaris 8 using gcc 3.3.2.  The build
> fails when it gets to the 'tests' subdirectory, with undefined symbol
> vasprintf.  Same error happens with opencdk 0.5.1 and 0.5.2;  I've
> appended a snippet from building 0.5.2, below.

This is because Solaris 8 doesn't have vasprintf - it's unfortunately
rather common for developers using Linux/FreeBSD etc to make poor
assumptions regarding the availability of such functions.  I worked around
it by editing src/misc.c - there's a vasprintf function defined there but
an #ifdef causes it to only be defined on Win32.  Remove the #ifdef and
the included vasprintf function works fine for Solaris.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]