[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-gnutls] Re: ex-serv-pgp

From: dellanna
Subject: Re: [Help-gnutls] Re: ex-serv-pgp
Date: Mon, 12 Feb 2007 14:36:04 +0100
User-agent: Internet Messaging Program (IMP) 3.2.6

Scrive Matthias Urlichs <address@hidden>:

> Hi,
> For the record: Please use "ldd -r". it resolves all symbols and thus
> is able to find more problems than a plan "ldd".
With ldd-r it return the same output: =>  (0xffffe000) => /usr/local/lib/ (0xb7f0e000) => /usr/local/lib/
(0xb7efa000) => /usr/lib/ (0xb7ecb000) => /usr/lib/ (0xb7e7f000) => /usr/lib/ (0xb7e7b000) => /usr/lib/ (0xb7e67000) => /lib/tls/i686/cmov/ (0xb7d38000) => /lib/tls/i686/cmov/ (0xb7d22000) => /usr/lib/ (0xb7cb9000)
        /lib/ (0xb7fa5000) => /usr/lib/ (0xb7ca9000)

> > =>  (0xffffe000)
> > => /usr/local/lib/ (0xb7ef6000)
> > => /usr/local/lib/
> > (0xb7ee2000)
> > => /usr/lib/ (0xb7ca1000)
> Ugh. That may be a problem.
> I don't know if your Linux distribution uses versioned symbols for their
> libgnutls (Debian does). To find out, do
> $ objdump -p /usr/lib/
> $ objdump -p /usr/local/lib/
> and look for the section that says "Version definitions".
I use Ubuntu 6.06 and if I run  objdump -p /usr/lib/ it return
the following output in section "Version definitions" :
Version definitions:
1 0x01 0x0ebdb882
2 0x00 0x091de682 GNUTLS_1_2
And if I run objdump -p /usr/local/lib/ I see in the same
Version definitions:
1 0x01 0x0ebdb883
2 0x00 0x091de683 GNUTLS_1_3

This seems correct... What is your version of gnutls-cli?


This message was sent using IMP, the Internet Messaging Program.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]