[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

usb_keyboard not available as a terminal input?

From: Tom Yan
Subject: usb_keyboard not available as a terminal input?
Date: Sun, 21 May 2017 15:18:28 +0000

Hi all.

So I happened to have looked into terminal_input for a bit (that is, "console", 
the default, has always worked for me so far. I just look into it because of 
curiosity and possible future use case). I notice that there should be a 
"usb_keyboard", as documented here:

However, when I run `terminal_input` in the grub shell, I see this:

Active input terminals:
Available input terminals:
serial_* serial at_keyboard

And usb_keyboard is missing.

I tried `insmod usb_keyboard` and `terminal_input` again; while `lsmod` lists 
usb_keyboard, terminal_input still doesn't list it as an available input 
terminal. (at_keyboard is listed as an available input terminal before the 
module is loaded anyway. With `terminal_input at_keyboard; lsmod`, I can see 
that the setting of the terminal triggers the module load, and my keyboard no 
longer works after that because it is a USB keyboard connected to a USB port)

So did I miss something? Or is it just broken? I am using grub 2.02 (from Arch 

P.S. I am allergic to grub-mkconfig. my grub.cfg is written from sratch, with 
only `insmod efi_gop` in addition to the menuentry. (And that implies it is EFI 
grub, x86_64 variant, if that matters)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]