[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Running guix on nixos

From: Jeff Mickey
Subject: Re: Running guix on nixos
Date: Fri, 22 Jan 2016 13:43:41 -0800
User-agent: Notmuch/0.21 ( Emacs/24.5.1 (x86_64-unknown-linux-gnu)

* Ludovic Courtès <address@hidden> [2016-01-22 04:57]:
> I think there’s an impurity leading the build system to use lib64/
> instead of lib/.  Compare with what we get with “real” Guix:
> --8<---------------cut here---------------start------------->8---
> $ ls $(guix build -e '(@@ (gnu packages commencement) libstdc++)')
> include/  lib/  share/
> --8<---------------cut here---------------end--------------->8---
> Could it be that the above libstdc++ was built before you had enabled
> chroot builds?  Are you sure the chroot doesn’t contain /bin or anything
> like that?

$ ls $(guix build -e '(@@ (gnu packages commencement) libstdc++)')
include  lib  lib64  share

Aha! So I ran nix-garbage-collect (which deleted all the things),
rebuilt andd.... still the same :(

$ ls $(guix build -e '(@@ (gnu packages commencement) libstdc++)')
include  lib  lib64  share

> (Are you sure you don’t want to use guix-daemon?  :-))

What I would like as an end result is my host to be reproducible from a
`nixos-rebuild switch` command line, and then user's have access to
guix's wonderfulness. I'm realizing now also that if guix build's all of
it's own stuff anyways, then sharing the same daemon is just a win for
simplicity of runtime (only one daemon), but not much simplicity on disk
(still two profiles everywhere, almost an entirely separate graph on

So, I guess now I need to learn more about nix's configuration file to
get this set up in /gnu properly for users in a nixos way. An odd goal,
I admit.

Dankon por via helpo, Ludo!

  //  codemac

reply via email to

[Prev in Thread] Current Thread [Next in Thread]