[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Error in config.scm

From: Kete Foy
Subject: Error in config.scm
Date: Wed, 8 Jun 2016 23:18:39 +0000

I got this error when trying to initialize the guix system:
/mnt/etc/config.scm:8:0: error: source expression failed to match any

My config.scm is available at
What I tried was changing the sda1 to sda since the template says sdX
and not something like sdXY. It didn't make a difference.

I made sure I used the label /my-root/ by looking at the history of
commands. I made the ext4 filesystems on both partitions (one after

The comment is blank/nil. This config worked before with minor changes.
It failed when guix tried to install Grub on the entire encrypted root
because as some know, that is not supported yet.

I am on freenode, too.
Key fingerprint = D7E9 5431 9C95 097F C314  C2A2 DD8C 15BD 0168 5E3A

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]