[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Guix package for gnutls-guile

From: Roel Janssen
Subject: Re: Guix package for gnutls-guile
Date: Fri, 17 Jun 2016 10:30:49 +0200
User-agent: mu4e 0.9.17; emacs 24.5.1

Ludovic Courtès writes:

> Hi!
> Tobias Geerinckx-Rice <address@hidden> skribis:
>> On 17/06/16 00:25, Roel Janssen wrote:
>>> Yet, even with gnutls in my profile, and running:
>>>   `guix package --search-paths`
>>> I still get the following error output:
>>> ;;; Failed to autoload make-session in (gnutls):
>>> ;;; ERROR: missing interface for module (gnutls)
>>> ERROR: In procedure module-lookup: Unbound variable: make-session
>>> What else could cause this error output?
>> It seems to happen a lot. This thread[1] solved that error for me. YM,
>> as always, MV...
> Yeah, it should be a “simple matter” of setting ‘GUILE_LOAD_PATH’.
> ‘guix package --search-paths’ will not tell you that unless both Guile
> and GnuTLS are in your profile.

My Guile paths are fine:

address@hidden ~]$ env | grep guile

And I verified that:

Is there anything else that can cause this error output?
Doesn't 'make-session' have anything to do with it?

Kind regards,
Roel Janssen

reply via email to

[Prev in Thread] Current Thread [Next in Thread]