[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

recordmydesktop doesn't work with sound.

From: Dmitry Nikolaev
Subject: recordmydesktop doesn't work with sound.
Date: Thu, 21 Jul 2016 22:58:07 +0300

Hi. I wanted to make a screencast about GuixSD, but recordmydesktop couldn't record sound. Launching it without parameters gives

Error while opening/configuring soundcard /dev/dsp

Manual page says I could specify sound device

                  Sound  device(default  hw:0,0  or  /dev/dsp,  depending   on
              whether ALSA or OSS is used).

I've tried both, hw:0,0 and /dev/dsp, none worked.

Meanwhile, I've tried to record my microphone with audacity and succeded, no configuration requred. By default audacity records from ALSA hw:0,0.

What should I do? Can I solve this issue with JACK, or it wouldn't help either? Shouldn't recordmydesktop package be recompiled with ALSA support? I thought it already has it. recordmydesktop is compilled with

(build-system gnu-build-system)

with no options, everything is default.

recordmydesktop- --help has a list of otional features

Optional Features:
  --disable-option-checking  ignore unrecognized --enable/--with options
  --disable-FEATURE       do not include FEATURE (same as --enable-FEATURE=no)
  --enable-FEATURE[=ARG]  include FEATURE [ARG=yes]
  --disable-dependency-tracking  speeds up one-time build
  --enable-dependency-tracking   do not reject slow dependency extractors
  --enable-oss=yes    compile with OSS(don't check for ALSA)
  --enable-jack=yes    compile with Jack support

As I can see ALSA is a default option. Why doesn't recordmydesktop in GuixSD doesn't work with my microphone like audacity does?

Dmitry Nikolaev

reply via email to

[Prev in Thread] Current Thread [Next in Thread]