[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: locale warning and postgresql

From: Ludovic Courtès
Subject: Re: locale warning and postgresql
Date: Tue, 29 Nov 2016 13:54:21 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.1 (gnu/linux)


Myles English <address@hidden> skribis:

> on [2016-11-28] at 20:48 Ludovic Courtès writes:
>> Myles English <address@hidden> skribis:
>>> I have always had trouble with my locale after installing guix on Arch
>>> Linux (with zsh and a basic window manager, bspwm).  I have set
>>> GUIX_LOCPATH in ~/.zshenv and it appears correct in my shell.  The
>>> system-wide locale looks right.
> I should say that I have tried guix several times and usually (always?)
> get the locale warning.
>>> When I install postgresql it gives the usual "warning: failed to
>>> install locale: Invalid argument".  When I try to initialise a
>>> database cluster, passing the locale doesn't work.
>>> Does anyone using Arch Linux and a basic WM know which file to put
>>> GUIX_LOCPATH in so that the warning goes away?
>>> How can I find out what guix thinks its locale is or what are available?
>>> Is there a way to use initdb even though there is a locale warning?
>>> Shell experiments:
>>> $ locale
>>> LANG=en_GB.UTF-8
>>> LC_CTYPE="en_GB.UTF-8"
>>> LC_NUMERIC="en_GB.UTF-8"
>>> LC_TIME="en_GB.UTF-8"
>>> LC_COLLATE="en_GB.UTF-8"
>>> LC_PAPER="en_GB.UTF-8"
>>> LC_NAME="en_GB.UTF-8"
>>> LC_ADDRESS="en_GB.UTF-8"
>>> LC_ALL=
>>> $ echo $GUIX_LOCPATH
>>> /home/myles/.guix-profile/lib/locale
>> What does “ls $GUIX_LOCPATH/2.24” show?
> $ ls $GUIX_LOCPATH/2.24
> ls: cannot access '/home/myles/.guix-profile/lib/locale/2.24': No such file 
> or directory
> Ah Hah!

See?  :-)

>> You must make sure you have the ‘glibc-locales’ or ‘glibc-utf8-locales’
>> that correspond to the glibc version of the program you are using (if
>> you just installed postgresql, it’s using glibc 2.24.)
> So I need to reinstall glibc-utf8-locales?  But alas...
> $ guix package -i glibc-utf8-locales
> warning: failed to install locale: Invalid argument     <<< Grrrrr! Bad guix! 
> Naughty!

At this point, I wouldn’t mind getting rid of this message altogether.

> Then I tried:
> $ guix graph --type=bag-emerged postgresql | dot -Tpdf > dag.pdf
> which I think shows that postgresql 9.5.3 depends on
> glibc-utf8-locales-2.23.

This is showing you compile-time (not run-time) dependencies of
postgresql, possibly a version other than the one you installed.

> How can I install  glibc 2.24 ?

If you install a postgresql from a recentish Guix, it’ll be linked
against glibc 2.24.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]