[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Hosting a GuixSD server on commodity hosting platforms, a journey

From: Christopher Allan Webber
Subject: Hosting a GuixSD server on commodity hosting platforms, a journey
Date: Tue, 29 Nov 2016 13:59:07 -0600
User-agent: mu4e 0.9.16; emacs 25.1.1

Hello all,

I tried getting GuixSD working on Rackspace Cloud last night.  Ludovic
suggested I write to the list to talk about my success/failure,
regardless of whether I made it or not.  My goal is to get GuixSD hosted
reliably on *some* commodity hosting platform, whether it's Rackspace or
Linode or Digital Ocean or something.  This thread will document my

Well, last night as my first go, I didn't succeed.  I decided to try to
see if I could upload an image generated with "guix system vm-image" and
then upload it and see if I could get it to boot from somewhere in the
UI.  Here are the things I looked at:

   Which just says that the file should be in the VHD file format and
   not a lot else (my image didn't exceed limits).
   I converted it like:
     qemu-img convert /tmp/guix-qemu-image.qcow2 -O vpc 
 - Trying to figure out how to upload and activate it, I took a look at:
   AFAICT, all these links say are how to upload an image to the
   OpenStack Cloud Files containers.  Okay, well by the time I read this
   I had already uploaded it via the web UI, so I don't see how it would
   be different, with the exception that I didn't use the container name
   "uploaded-images", which it doesn't seem to explicitly require.  So
   effectively, my image was uploaded and resulted in the same place
   afaict, though I just used the web UI rather than the API.
 - Next I tried to boot it.  I went to "Servers -> Cloud Servers" from
   the dropdown menu at the top, then clicked "Create Server".  I
   clicked "Saved"... but there's nothing there.

What am I doing wrong?  I'm not totally sure... I feel like I'm
navigating a jungle out here in the OpenStack / Rackspace docs.  Here's
one thing I found:

So I probably need to execute this "import" command.  I guess that's
what's next...

What happens if that doesn't work?  I've been looking at how the Nix
community does things.  Most of the guides seem to involve taking an
existing distribution and converting it.

That seems really goofy, but okay, I guess we could do it.

Does anyone else know more about these things than I do?  Your feedback
and experience most welcome!

 - Chris

reply via email to

[Prev in Thread] Current Thread [Next in Thread]