[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ath wireless power management failure

From: Björn Höfling
Subject: Re: ath wireless power management failure
Date: Tue, 7 Feb 2017 22:39:28 +0100

Hi Ricardo,

On Sun 05 Feb 2017 04:43:26 AM CET
Ricardo Wurmus <address@hidden> wrote:

> GPG: BCA6 89B6 3655 3801 C3C6  2150 197A 5888 235F ACAC
> Hi Guix,
> since a couple of days I’m experiencing problems with my wireless card
> after waking up from suspend.  I suspend the laptop very often, so
> this is really important to me.
> Upon waking up from suspend the wireless card cannot be initialised
> any more.  This results in a constant stream of error messages, which
> can be seen in dmesg.  The messages disappear when unloading all
> ath-related kernel modules.  Reloading the modules does not return
> the network card to a workable state, so I have to reboot if I want
> to connect to a wireless network (and I usually want to do that).
> The error messages that appear in the log look like this:
> --8<---------------cut here---------------start------------->8---
> [ 1210.998408] ath: phy0: Unable to reset channel, reset status -22
> [ 1211.078027] ath: phy0: DMA failed to stop in 10 ms
> AR_CR=0xffffffff AR_DIAG_SW=0xffffffff DMADBG_7=0xffffffff
> [ 1211.078038] ath: phy0: Could not stop RX, we could be confusing
> the DMA engine when we start RX up --8<---------------cut
> here---------------end--------------->8---
> (Repeat ad infinitum.)
> According to ancient bug reports these messages relate to power
> management problems and have been reported as fixed a long time ago.
> I confirmed with “iw” and “iwconfig” that power management for my WiFi
> card is in fact disabled (I didn’t do this myself).
> I see these errors with linux-libre-4.1 and linux-libre.  I’m using
> a somewhat dated Libreboot (planning to upgrade *after* FOSDEM to be
> sure that my machine is usable for the presentation).
> Has anyone else experienced the same behaviour?  Any ideas how to fix
> this?  Does this just mean that my WiFi card is dying?

Just curious:

Is you operating system GuixSD? Do you still have an old system generation of
the time "where it worked"? Have you tried to boot into that?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]