[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Help with Ruby: rouge 2.0.7

From: Björn Höfling
Subject: Help with Ruby: rouge 2.0.7
Date: Tue, 14 Mar 2017 23:08:58 +0100


I want to import the Ruby package 'rouge' 2.0.7 into Guix. I'm new to
Ruby, Gem, Rake, etc. and tried the importer with some success. Maybe
someone with more Ruby experience can tell me what's the right way here?

OK, I thought this is an easy one, because it has no dependencies:

I started with:

guix import gem rouge > rouge.scm

Then added some import headers in the file and tried to build it with

guix build -f rouge.scm -k -K --rounds=2

But it failed:

phase `build' succeeded after 0.4 seconds
starting phase `check'
rake aborted!
No Rakefile found (looking for: rakefile, Rakefile, rakefile.rb,

(See full trace by running task with --trace)
phase `check' failed after 0.1 seconds

Yes, there is no Rakefile in


It seams this is not bundled into the Gem. Also the spec folder is not
there. Is that usual behaviour? If so, is 'guix import gem' the right

If I skip the tests via:

   '(#:tests? #f))

it works. But I want tests. So I tried it with the package from github:

(uri "";)

It has a Rakefile, but I have to modify the test target name:

(arguments '(#:test-target "spec"))

And I have to add some inputs, although on the RubyGem site, there are
neither dev nor runtime dependencies declared:

   `(("ruby-minitest-4" ,ruby-minitest-4)
     ("bundler" ,bundler)))

OK, let's get started:

address@hidden ~/guix [env]$ ./pre-inst-env guix build -f rouge-git.scm
--rounds=2 -k -K

`block in verify_gemfile_dependencies_are_found!': Could not find gem
'wrong' in any of the gem sources listed in your Gemfile.

Does that mean that I have to install
'wrong' ( that itself has 5
dependencies, 4 are not in Guix?

What's your Guix/Ruby advice here?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]