[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: I can only start an X server in guix as root

From: pelzflorian (Florian Pelz)
Subject: Re: I can only start an X server in guix as root
Date: Sat, 18 Mar 2017 15:50:49 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Icedove/45.8.0

On 03/18/2017 01:50 AM, Joshua Branson wrote:
>     Hello,
> I currently dual boot guixSD and Parabola.  I use a macbook 7,1, and I
> am unable to start an X server in guix as my normal user.  I can login
> to gnome via my root user, but obviously this is not ideal.  I can login
> to a virtual console as my normal user and access Emacs (yeah), but it
> would be nice to be able to start gnome as my normal user.  Just today I ran
> guix pull; sudo guix pull; guix system reconfigure /etc/gnome-xfce.scm
> It updated fine.  I rebooted and the problem still persists.  Parabola
> and guix have seperate / partitions, but they share the same /home.  
> I've set up guix to create my normal user (joshua) with a uid of 2000,
> because that is the uid that the user joshua has on parabola.
> I'm attaching my config.scm file and some errors that I've found that
> are probably relevant.  Any help would be nice. 

So I’m not going to be of much help, but I want to rule out the obvious:
For me most of the time GNOME starts only on the second log-in attempt
on GuixSD. I assume you have tried logging in multiple times in a row?

Other than that I see no significant differences between my config file
and yours, but I haven’t tried.

> grep EE Xorg.1.log
> [    47.080] Current Operating System: Linux parabola 4.10.1-gnu-1 #1 SMP 
> PREEMPT Mon Feb 27 17:40:02 UYT 2017 x86_64
>       (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

Why does your log say Parabola?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]