[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: torsocks works with wget but fails git-clone: "unable to lookup symb

From: ng0
Subject: Re: torsocks works with wget but fails git-clone: "unable to lookup symbols in"
Date: Thu, 6 Apr 2017 21:54:42 +0000

Mekeor Melire transcribed 1.0K bytes:
> ng0 <address@hidden> writes:
> > That's not enough for torify (torification? to use torsocks / the SOCKS5
> > of tor) of applications. As I told you earlier, you need a SOCKSPort,
> > like so:
> >
> > (services (cons*
> >             (tor-service
> >               (plain-file "torrc"
> > "SocksPort\n"))))
> >
> > This can be extended any other values you can find in "man torrc" as
> > long as you end the lines with "\n".
> >
> > The (tor-service) is mostly just usable for offering onion services, and
> > we should document that the default is to leave it up to the person
> > using the system to
> > configure more behavior.
> >
> Why does the exact same command, namely “torify git clone
>” work for other people on GuixSD then
> without any custom tor-config but just (tor-service)? (Like, in
> particular, I remember that rekado told me so.)
> Also, after reconfiguring with the snippet you suggested, I still get
> the same error.
> --
> mekeor ~ EDD3 DFFA 76F6 11C0 145F 9A99 AC85 BAD8 A2F8 C868

Okay that is weird...

Okay, you need the SOCKSPort to make use of the SOCKS5 proxy. Apparently
torify is something else and I forgot about that. Sorry.

I assume your system and profile are recent enough?
I have never experienced this error, so I can't really help.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]