[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: offload daemon

From: James Richardson
Subject: Re: offload daemon
Date: Wed, 24 May 2017 21:10:53 -0400
User-agent: mu4e 0.9.18; emacs 25.2.1

Ludovic Courtès writes:

> James Richardson <address@hidden> skribis:
>> James Richardson writes:
>>> Ludovic Courtès writes:
>>>> Hello,
>>>> James Richardson <address@hidden> skribis:
>>>>> I am trying to setup an offload daemon.
>>>>> I have everything setup correctly (I think ;)
>>>>> $ guix offload test completes successfully.
>>>>> The offload daemon is actually guix on a foreign distro (Debian sid in
>>>>> this case).
>>>>> Neither guix running on top of a Debian (sid and jessie) nor guixsd seem
>>>>> to even call out to the offload daemon. All boxen are 64.
>>>>> My /etc/guix/machines.scm is here
>>>>> (list (build-machine
>>>>>        (name "")
>>>>>        (system "x86_64-linux")
>>>>>        (host-key "ssh-ed25519 
>>>>> AAAAC3NzaC1lZDI1NTE5AAAAIJf0ezYgeVFit40VJwaBEW1dGm2Xz+SHzVmib8IbN58y 
>>>>> address@hidden")
>>>>>        (user "guix")
>>>>>        (speed 1.)
>>>>>        (private-key
>>>>>   (string-append (getenv "HOME")
>>>>>                  "/.ssh/identity-for-guix"))))
>>>>> Is x86_64-linux the proper system type?
>>>> Yes.
>>>> There are several things to consider here.  By default, guix-daemon
>>>> creates a single job, so that single job will end up being built
>>>> locally, unless you spawn, say, two “guix build” commands in parallel
>>>> (the number of jobs is per client.)
>>>> Running “guix-daemon --max-jobs=0” should force all builds to be
>>>> offloaded:
>>>> I *think* “guix build --max-jobs=0” should give the same result.
>>>> Alternately, if you run “guix build --max-jobs=2”, presumably half of
>>>> the builds will be offloaded.
>>>> Let us know if that works for you.
>>>> Ludo’.
>>> I have a permission problem somewhere, I think. If I run as root offload
>>> works, otherwise it doesn't. Don't really know here to look from here.
>> Hmm, I move the key pair to /tmp and set the perms to 644 and offloading
>> works for my regular user... Not quite sure I understand why.
> The ‘guix offload’ command is invoked by guix-daemon as root.  So when
> it is invoked, (getenv "HOME") returns "/root" or similar.  Could that
> be the problem?
> HTH,
> Ludo’.

Well, I think there is an issue with the offload. I don't (yet) know
guile well enough to understand the code to help :(

Here is what I am finding: $ guix build blah seems to offload builds
properly. $ guix package -i blah, guix package -u blah, and $ guix
system reconfigure config.scm does not offload builds.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]