[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Kernel panic - not syncing: attempting to kill init! when booting Gu

From: Christopher Baines
Subject: Re: Kernel panic - not syncing: attempting to kill init! when booting GuixSD
Date: Tue, 30 May 2017 13:43:40 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.8.0

On 28/05/17 16:49, Ludovic Courtès wrote:
> Hi Christopher,
> Christopher Baines <address@hidden> skribis:
>> So I deleted some system generations from one of my GuixSD systems, then
>> rebooted. Unfortunately, I can no longer get it to boot. I think the
>> latest system generation should work, and at least one of the previous
>> generations should work.
>> Excluding the generations that I removed, the others don't boot. All I
>> can really gather so far is a call stack, and the message:
>>   Kernel panic - not syncing: Attempted to kill init!
> Weird.  Is it because the root file system could not be found?  Or
> something else?  Like Ricardo wrote, could it be that the file system
> label changed or something?

Looking at the file system and configuration, it seems that this is

>> I'm going to try and make some time to see if I can get this system back
>> working again. I'm not sure how realistic this is, but I'm planning to
>> start by using the installation image, and somehow running  guix system
>> reconfigure.
> I would suggest booting from an external medium such as the installation
> image, mounting the file system that holds /gnu/store, and inspecting
> there.
> Also worth trying: you could edit the command line in the GRUB menu to
> have it refer to /var/guix/profiles/system-NNN-link, where NNN is the
> number of a previous generation known to be on disk.

I don't have the right cables to attempt to get a serial connection to
see what is going on in the early boot, so I tried running guix system
init from some GuixSD installation media. I'm glad to say that it worked :)

After running guix system init, I had a working system generation to
boot with.

I'll try to setup some kind of serial connection, so that I can attempt
to debug further if this happens again.



Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]