[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Xorg won't start

From: someone
Subject: Xorg won't start
Date: Mon, 12 Jun 2017 10:37:26 +0200 (CEST)

Im unable to start Xorg on one of my laptops - can't get to slim or start a desktop service with xfce4start etc.

At the second to last line of Xorg.0.log I have:
  systemd-logind: logind integration requires -keeptty and -keeptty was not 
provided, disabling logind integration
full log is at

Is there a way to fix this?

For the sake of testing I then ran guix package -i libdrm && mpv --vo drm my_vid.wmv which hangs the console (not the pointer but can't cancel the process) and Im unable to switch tty.

I also tried changing slim to sddm and setting wayland instead of X11 but that didn't help. I also tried to define my-slim-service and add the nouveau driver in case there's a problem with the intel graphics but I weren't able to write it correctly, this didn't work:

(define (my-slim-service)
        (mlet* %store-monad ((config (xorg-configuration-file
;;              #:drivers '("nouveau" "vesa")
                #:resolutions '((1920 1080) (1366 768) (1024 768))
                             (startx (xorg-start-command
                #:configuration-file config)))
        (slim-service #:startx startx)))
(services (cons* (xfce-desktop-service)

Any ideas, anyone?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]