[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: failed to resolve partition “my-root”

From: Ludovic Courtès
Subject: Re: failed to resolve partition “my-root”
Date: Thu, 29 Jun 2017 16:37:34 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.2 (gnu/linux)

Ricardo Wurmus <address@hidden> skribis:

> Fixing this was tedious, though.  Before the installation I ran “guix
> pull”.  When I noticed that the system would not boot I had to boot from
> USB again — and then would have to run “guix pull” again.
> Is there a way to avoid this?  We can’t just chroot and my attempts to
> just bind mount /mnt/gnu and /mnt/var/guix after booting the disk image
> from USB failed; at least when building software because the build
> environment appears to fail when things are bind mounted.
> I couldn’t just use Guix from /mnt/gnu, because it uses symlinks to
> /gnu, which are all broken when /gnu is provided by the USB disk.
> Should I have used some unionfs trickery?

Maybe with unshare + chroot as in
but then you’d need to be able to start the daemon in that environment
with “/run/current-system/profile/bin/guix-daemon
--build-users-group=guixbuild”.  I haven’t tried, it’s quite
inconvenient, but it may work.

> Is there a “fixup recipe” we can recommend to people in the manual for
> those cases where the initrd doesn’t contain the necessary kernel
> modules?  Or maybe a “guix system enter /mnt” command that remounts
> things and creates user accounts as necessary?

I like the idea of “guix system enter” and it shouldn’t be that hard.
Perhaps a wishlist item for bug-guix?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]