[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Issues with my configuration

From: Ricardo Wurmus
Subject: Re: Issues with my configuration
Date: Tue, 04 Jul 2017 11:30:25 +0200
User-agent: mu4e 0.9.18; emacs 25.2.1

Hi Fredrik,

> 1)  Mounting a nfs disk.
> I tried adding the nfs mount to file-systems.
>> (file-system
>>    (device "fafner:/srv/nfs4/Valhalla")
>>    (title 'device)
>>    (mount-point "/media/Valhalla")
>>    (type "nfs4")
>>    (check? #f))
> It works after I reconfigure guix
>> sudo guix system reconfigure /etc/config.scm
> But when I reboot, guixsd will not start it just hangs in the boot process.
> Looks like a lot of services are failing.

Do you want this to be mounted on boot?  I don’t think there’s a way to
express that a mount should happen after the network has come up (yet).

You can only tell Guix not to try to mount the disk on boot.  Use
auto-mounting to mount the disk on demand at a later point.  (We don’t
have a service for autofs yet.)

Your contributions in this area would be welcome!

> 2) Change shell for user to zsh.
> I followed on how to change
> shell to zsh but getting this error when reconfiguring:
>> guix system: error: failed to load '/etc/config.scm':
>> ice-9/boot-9.scm:2795:6: In procedure resolve-interface:
>> ice-9/boot-9.scm:2795:6: no code for module (gnu packages zsh)

There is no module “(gnu packages zsh)”.  “zsh” is now in “(gnu packages

> 3) Keyboard mapping.

> The question is how do I translate this to GuixSD? Closest I could find in
> the manual was about the X window, but didn't find anything that directly
> matches what I want.

Here’s what I do in my config:

--8<---------------cut here---------------start------------->8---
(define dvorak-evdev
  (call-with-input-file "/etc/config.d/evdev.conf" read-string))


(operating-system …
  (services …
    (modify-services %desktop-services
       config => (slim-configuration
                  (inherit config)
                  (startx (xorg-start-command
                            (list dvorak-evdev))))))
--8<---------------cut here---------------end--------------->8---

You can use something like that to add to the xorg configuration file.
Just put your snippet in a file and slurp it up.

> 4) /bin/env
> In the manual, under Base Services
> <> it
> describes how to add env to /bin. I tried adding that snippet to my
> services but I don't see env in /bin after I reconfigure.

Not sure about this one.  Your config looks okay to me.  I’m not using
this myself, so I don’t know if there’s a bug in our documentation.

> I've also noticed some odd issues with my keyboards that are running the qmk
> firmware <>. I've setup that my space
> have a dual action, it's register as space when pressing and ctrl when
> holding the key. But when using them in GuixSD it results in a 1s delay
> every time I press space. Which gives a very sluggish impression when
> typing in the terminal. It works fine if I disable that feature. I have not
> experienced that issue in any other distro.

Don’t know about this one.  Is any kernel firmware loading mechanism
involved or do you suspect an xorg configuration problem?


GPG: BCA6 89B6 3655 3801 C3C6  2150 197A 5888 235F ACAC

reply via email to

[Prev in Thread] Current Thread [Next in Thread]