[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: grub not properly installing in GuixSD

From: Joshua Branson
Subject: Re: grub not properly installing in GuixSD
Date: Mon, 17 Jul 2017 20:23:54 +0000

I do actually have swap devices in the config file.  I just didn’t want to re-write the entire config file.  :)    

That is true.  I do have /dev/sda1 tagged as bootable and as esp.  

parted p shows

/dev/sda1  flags:  boot, esp   file system  fat32,   Size 537MB

And you are seeing that missing parenthesis because my config has a menu-entries to specify that I dual boot.

(bootloader  …
                   (label “Parabola”)
……. )   ;; closing parenthesis for the (bootloader

If I was missing parenthesis, guix would have given me an error when I tried to init the system.  So I believe that my parenthesis are in order.  :)

Thanks for the speedy response.  I’m sure I’ll figure it out eventually.

I suppose that part of the problem could be that /dev/sda1   already has grub installed on it.  When I installed Arch linux, it used /dev/sda1 as the partition to install guix.   /dev/sda1 is the partition that is flagged as bootable, and right now it’s configured to load grub then boot Arch linux.     If I install grub again on /dev/sda1, will grub be smart enough to load guixSD?    It might be wiser to delete- and re-create /dev/sda1.  That way guixSD will install  on blank slate.  The only problem is, that might break my boot process.  If I can get to a boot command line, I know how to boot Parabola.  But issues bro.  issues.

P.S.  If you are interested in learning more about MBR, EFI partition, UEFI, and GPT, then you should take a look at this wiki:       It gives you a good overview.  

On Jul 17, 2017, at 3:28 PM, Joshua Branson <address@hidden> wrote:


I’m currently trying to dual boot Arch Linux and GuixSD on a desktop machine that I built.  GuixSD seems to be installing well, but grub in not properly installing.  I’m trying to boot using grub-efi.   

After I run guix system init /mnt/etc/bare-bones.scm  /mnt

I get this error:

grub-install: error: /gnu/store/ipwgwqaarp304r82…….-grub-efi-2.02/lib/grub/i386-pc/ doesn’t exist.  Please specify —target or —directory.

guix system: error: failed to install GRUB on device /dev/sda1

I believe that for some reason guixSD is install guix in a BIOS way.  At least that’s what this ask ubuntu forum says:   Apparently grub should be trying to install via X86_64….

Now here’s detail about my set up.

parted p
/dev/sda1     500MB or so     vfat partition.  
/dev/sda2     20 GB  Arch root
/dev/sda3    1GB swap
/dev/sda4    /home    for both Arch and GuixSD
/dev/sda5   /   for GuixSD.

The partition table is using GPT.  

Arch linux is already installed.  It boots using UEFI, but Arch mounts /dev/sda1  to /boot.

I booted guixSD via a usb-stick.  I believe that I booted in BIOS mode.  I was unable to get the usbstick to boot via UEFI.

mount /dev/sda5 /mnt

mkdir -p /mnt/boot/efi

mount /dev/sda1 /mnt/boot/efi

mkdir /mnt/home

mount /dev/sda4 /mnt/home  

swapon /dev/sda3

Then I ran guix system init.  

I don’t want to completely copy out my config file  (that would take a while), but here’s the gist of it.  At least the parts that deal with UEFI boot:

(use-modules (gnu) (gnu system nss))
(use-package-modules bootloaders  admin certs gnome)
(boot loader (grub-configuration
                        (grub grub-efi)
                        (device “/dev/sda1”)
(file-systems (cons*  (file-system
                                     (device “my-root”)   ;; //this is /dev/sda5
                                     (title ‘label)
                                     (mount-point “/“)
                                      (type “ext4”))
                                      (mount-point “/home”
                                      (device “/dev/sda4”)
                                      (type “ext4”))
                                       (device “/dev/sda1”)
                                       (mount-point “/boot/efi”)
                                       (type “vfat”))

I’m using a AMD CPU.  1TB hard drive.  And I don’t think there is much more that I can say at this point.   Is there a specific guix command to try to install grub?  What command would I run to install grub on /dev/sda1 so that it boots GuixSD?  



reply via email to

[Prev in Thread] Current Thread [Next in Thread]