[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Grub installation failed during the GuixSD's installation

From: Joshua Branson
Subject: Re: Grub installation failed during the GuixSD's installation
Date: Fri, 28 Jul 2017 13:48:57 +0000

Hey Ivan,

It sounds like you are having trouble installing grub, when you are booting via UEFI.  I may be able to point you in the general right direction.  I just solved my issue booting via UEFI.

When I installed guixSD, the install went fine, but grub could not properly install itself.  I got this error message when grub tried to install:

grub-install: error: /gnu/store/ipwgwqaarp304r82…….-grub-efi-2.02/lib/grub/i386-pc/ doesn’t exist.  Please specify —target or —directory.

My problem was that my computer is set up to boot in UEFI, but I booted the guixSD system via legacy boot.  Since I booted the legacy way, grub tried to install itself in the legacy way, which won’t work if you already have UEFI set up.  I would recommend that you try to boot guixSD in the UEFI way.  When you are presented with boot options on the usbstick grub screen, look for something that says UEFI.  You’ll then need to mount your EFI partition on /mnt/boot/efi  (this is explained in the guixSD install manual).  Your EFI partition should be near a 500MB fat32 (also called vfat).  It’s probably your /dev/sda1, but double check to be sure.

If you’re not sure if you’re booting in UEFI or or legacy boot, check your partition table.   As root run “parted”.  Then press “p”.  If you see a 500MB fat32 (also called vfat) partition, (maybe a bit bigger, maybe a bit smaller), then you are probably booting via UEFI.  If you don’t see that partition table, then you are probably booting via legacy boot.

If you are booting via UEFI then, disable legacy boot in your BIOS.  (You can access your BIOS by pressing F10 or F12, depending on your machine, when your machine boots).  This will ensure that your computer will only boot in UEFI mode.  

The other issue that I had was, when I tried to boot via UEFI from the usbstick, guixSD would not boot properly.  It would stop working about halfway through, and I’d get and error complaining about my radeon driver.  I fixed this by pressing “e” in the grub menu.  This lets you edit the current boot parameters.  I then added “nomodeset” to the linux command line.  Then guixSD booted fine.  

I added to the kernel arguments in my config file:

--8<---------------cut here---------------start------------->8---
  ‘("nomodeset"     ; Needed for using flashrom
--8<---------------cut here---------------end--------------->8---

Good luck,


P.S.  If you’re still confused about legacy boot vs. UEFI boot, try reading sections from the Arch wiki page:

The terminology you want to learn and understand is:

MBR  (master boot record)
GPT  (I forget what that stands for)
Legacy boot
UEFI boot
EFI partion

On Jul 28, 2017, at 5:07 AM, Ludovic Courtès <address@hidden> wrote:


Iván Hernández Cazorla <address@hidden> skribis:

I init the process to install GuixSD, everything seems to be correct
during the process. But at the end it shows an error that says that
was impossible to install the grub. I understand that GuixSD was
installed correctly, but the grub not.

Did the error message have something to do with UEFI?  Are you
installing on a UEFI machine?

If you could provide us with the actual error message and the
GuixSD configuration file that you used, that would be great!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]