[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Grub error: Failed to get canonical path of 'none'

From: Eduardo Thales
Subject: Grub error: Failed to get canonical path of 'none'
Date: Fri, 1 Sep 2017 18:22:07 -0300

I'm trying to install Guix SD with Grub on UEFI and my stuck in this error:
/gnu/store/4c7x0ji4mni5dayf8ig9rssk50pjims1g-grub-efi-2.02/sbin/grub-install: error: failed to get canonical path of 'none'.
guix system: error: failed to install bootloader /gnu/store/6kn22v26i3c6a7h41268z11zkki8y9jk-bootloader-installer

Here is my config:
(use-modules (gnu) (gnu system nss))
(use-service-modules networking ssh)
(use-package-modules admin bootloaders)

  (host-name "AcerThales")
  (timezone "America/Sao_Paulo")
  (locale "pt_BR.utf8")
  (bootloader (grub-configuration (grub grub-efi)
                                  (device "/dev/sda1")))

  (file-systems (cons* (file-system
                                     (device "guix")
                                     (title 'label)
                                     (mount-point "/")
                                     (type "ext4"))
                                     (device "home")
                                     (title 'label)
                                    (mount-point "/home")
                                   (type "ext4"))
                                    (device "/dev/sda1")
                                   (mount-point "/boot")
                                  (type "vfat"))

  (users (cons (user-account
                (name "eduardo")
                (comment "Eu msm")
                (group "users")
                (supplementary-groups '("wheel" "netdev"
                                        "audio" "video"))
                (home-directory "/home/eduardo"))

  (packages (cons* nss-certs                      

  ;; Allow resolution of '.local' host names with mDNS.
  (name-service-switch %mdns-host-lookup-nss))

I tried to follow what I found in the Reference Manual. Also, I tried to set (device "/dev/sda") in grub-configuration but no luck. Can someone give me some light? Thanks in advance

reply via email to

[Prev in Thread] Current Thread [Next in Thread]