[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: kodi crash, and gdb not found

From: Marco van Hulten
Subject: Re: kodi crash, and gdb not found
Date: Sun, 19 Nov 2017 18:08:51 +0100


Je 19 nov 17:36 transskribita far Marius Bakke:
> Marco van Hulten <address@hidden> writes:
> > I have `kodi' and `gdb' installed.  When I start kodi, it crashes:
> >
> >
> >
> > An excerpt of the `kodi' output:  
> >> gdb not installed, can't get stack trace.  
> >
> > but I installed gdb, under the same user:
> >
> >     address@hidden ~$ gdb --version | head -1
> >     GNU gdb (GDB) 8.0.1
> >
> > Interesting, `man gdb` does not gives an empty or unreadable man page:
> > at the bottom of the terminal is:  
> >> Manual page gdb(1) line ?/? (END) (press h for help or q to quit)  
> >
> > I have never before tried (to let a program) use gdb on GuixSD.
> >
> > Last Sunday, the program `kodi' worked fine.  Shortly after that
> > (according to lastlog(8) the same day), I did a package upgrade, but
> > did not test kodi hereafter (according to `history`).  Today, I tested
> > kodi and it crashes.  I upgraded packages, but then it still crashes.  
> Can you try rolling back to the generation that worked, to verify that
> it's not something in your environment that has changed?  Maybe also try
> to temporarily move away the ".kodi" folder in the users home directory.

Removing ~/.kodi/ did not solve the issue.

Rolling back sufficiently far did help.  My generations:

4 — kodi 18.0-ALPHA1 Git:20171106-nogitfound — works
5 — kodi 18.0-ALPHA1 Git:20171113-nogitfound — crashes

Fantastic feature this rolling back!

Sidenote: I see that the guix-profile symlink in
/var/guix/profiles/per-user/*/ is absolute; why no relative links?

> I'm currently testing the latest git snapshot of Kodi regardless, the
> alpha version in Guix is pretty old already.  Originally Kodi 18 was
> slated for July, but the release was pushed back to January[0], so the
> version in Guix is probably pretty buggy.

I installed GuixSD 0.13.0.  Hereafter, I have done a `guix pull` and
`guix package -u`, which resulted recently in

9 — kodi 18.0-ALPHA1 Git:20171113-nogitfound — crashes

That's six days ago; that's not that old, right?


Attachment: pgpTZuGcWMPzt.pgp
Description: OpenPGP digitale handtekening

reply via email to

[Prev in Thread] Current Thread [Next in Thread]