[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: How to build GnuCash with SQLite backend support?

From: Gary Johnson
Subject: Re: How to build GnuCash with SQLite backend support?
Date: Wed, 06 Dec 2017 20:28:50 -0500
User-agent: mu4e 0.9.18; emacs 25.2.1

Hi again,

After spending some time with the Guix manual, I managed to write up a
new package module that defines packages for libdbi, libdbi-drivers
(just sqlite3 support for now), and gnucash-with-dbi (see attached

Attachment: gnucash-with-dbi.scm
Description: Binary data

However, now I'm getting a new error when I pop this file on the

$ guix package -i libdbi-drivers

checking for libdbi framework... checking dbi/dbi.h usability... yes
checking dbi/dbi.h presence... yes
checking for dbi/dbi.h... yes
checking for MySQL support... no
checking for PostgreSQL support... no
checking for SQLite support... no
checking for SQLite3 support... yes
checking sqlite3.h usability... yes
checking sqlite3.h presence... yes
checking for sqlite3.h... yes
checking for library containing sqlite3_exec... -lsqlite3
checking for Msql support... no
checking for Oracle support... no
checking for Firebird/Interbase support... no
checking for Freetds support... no
checking for Ingres support... no
checking for IBM DB2 support... no
checking for strtoll... yes
checking for atoll... yes
checking for vasprintf... yes
checking for asprintf... yes
checking for libdbi library... no
configure: error: Invalid libdbi directory - include files not found.
phase `configure' failed after 2.5 seconds
builder for 
`/gnu/store/nxm3ivpsngf7k9rcszry30hyjpx65iqw-libdbi-drivers-0.9.0.drv' failed 
with exit code 1
guix package: error: build failed: build of 
`/gnu/store/nxm3ivpsngf7k9rcszry30hyjpx65iqw-libdbi-drivers-0.9.0.drv' failed

Okay, guys. What the heck am I missing here? I've clearly added the
libdbi and sqlite packages to the "inputs" list of the libdbi-drivers
package. The configure phase is detecting dbi.h and sqlite3.h just fine,
but then it can't find the libdbi library? Now I'm definitely lost. :(

I tried sticking libdbi into propagated-inputs and even into
native-inputs with exactly the same result.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]